Installation of Storage Foundation 6.0 and 6.0.1 fails due to missing rpms


Installation of Storage Foundation 6.0 and 6.0.1 fails due to missing rpms. When performing a preinstall check (installer -precheck) for Storage Foundation (SF) 6.0 / 6.0.1 on RedHat Linux 6.2 / 6.3 release, it complains about the required operating system (OS) rpms not being installed, despite that the latest release of rpms have been installed on the system.

Error Message

CPI ERROR V-9-30-2225 The following required OS rpms (or higher version) were not
found on system1:
        nss-softokn-freebl-3.12.9-3.el6.i686 glibc-2.12-1.25.el6.i686
pam-1.1.1-8.el6.i686 libstdc++-4.4.5-6.el6.i686 libgcc-4.4.5-6.el6.i686


CPI installer recognizes the higher version of required rpms.

However, in this case, the required rpms for [rpmname]-[version].i686' (.i686 extension) were missing on the system. Irrespective of whether the platform is x86_64 or i686, SF 6.0 (and above) requires certain required OS rpms for both platforms, i.e., x86_64 and i686 to be installed.
        "glibc"  =>  "glibc-2.12-1.25.el6.i686 glibc-2.12-1.25.el6.x86_64",
        "libgcc"  =>  "libgcc-4.4.5-6.el6.i686 libgcc-4.4.5-6.el6.x86_64",
        "libstdc++"  =>  "libstdc++-4.4.5-6.el6.i686 libstdc++-4.4.5-6.el6.x86_64",
        "nss-softokn-freebl(x86-32)"  =>  "nss-softokn-freebl-3.12.9-3.el6.i686",



These libraries are maintained by Red Hat which has other libraries associated. 

For installing the Storage Foundation required libraries <library software with adv version.i686.rpm>


1) Install the following rpm with rpm -ivh command

2) Configure the Yum server and install 




Applies To

RedHat Enterprise Level (RHEL) 6

Storage Foundation 6.0, 6.0.1

Terms of use for this information are found in Legal Notices.



Did this article answer your question or resolve your issue?


Did this article save you the trouble of contacting technical support?


How can we make this article more helpful?

Email Address (Optional)