Accelerator Export to PST fails to move files and logs error 'System.Runtime.InteropServices.COMException (0x8004010E)'
Problem
Enterprise Vault (EV) Compliance Accelerator (CA)/Surveillance or Discovery Accelerator (DA) Export to PST fails to move one or more files into the PST with the error(s) listed below.
Error Message
Source: Accelerator Service Processor
Category: None
Event ID: 235
Event Type: Error
Description:
APP AT - Customer ID: X - An error occurred when requesting the PST COM object. System.Runtime.InteropServices.COMException (0x8004010E): Exception from HRESULT: 0x8004010E
at KVS.EnterpriseVault.Interop.PSTProviderClass.EnableMAPI()
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.get_ThePSTProvider()
V-437-235
Source: Accelerator Service Processor
Category: None
Event ID: 236
Event Type: Error
Description:
APP AT - Customer ID: X - [ExportPST] - Error moving some messages to PST for run '...' : System.Runtime.InteropServices.COMException (0x8004010E): Exception from HRESULT: 0x8004010E
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.HooverUpMsgsToPst(Boolean bLastItem, ConcurrentQueue`1 filesMovesToPST)
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.StartPSTExport(Boolean isLastItem)
V-437-236
Cause
The Export process first extracts the messages from EV Storage and then provides the messages to CA/DA to be converted to PST files using Microsoft Outlook installed on the Accelerator server. The most common causes of the error(s) are (1) the items do not exist in Storage, (2) an unsupported or unlicensed version of Outlook is installed, (3) FixMAPI.exe needs to be run to fix the MAPI profiles, (4) the DA server requires a reboot to clear the temporary MAPI profiles.
Solution
One of the most common fixes for these errors is to reboot the Accelerator server and then retry the Export. If rebooting the Accelerator server does not resolve the error(s), then review the following:
1. Confirm the failed items exist in Storage. To do this, run the EVSVR DumpSaveset command for the failed items. The HTML Export Report should list the SavesetID and ArchiveID (VaultID). See Related Articles below for Article How to extract the Saveset and SIS parts of a specific archived item using EVSVR.
2. Verify a supported version of Outlook is installed on the Accelerator server. See the latest Compatibility Guide for the supported Outlook versions (review any associated footnotes).
3. Run FixMAPI.exe to resolve any Outlook profile issues on the Accelerator server.
3.1. Use one of the following methods to run the FixMAPI utility:
3.1.1. Use File Explorer to navigate to C:\Windows\System32\, then double-click on fixmapi.exe.
3.1.2. Open an administrative/elevated command prompt (Start, right-click Command Prompt, and then click Run as administrator), navigate to C:\Windows\System32\, then execute fixmapi.exe.
Note: The FixMAPI.exe command does not provide any confirmation that it is completed.
3.2. Reboot the Accelerator server.