NetBackup Web UI catalog recovery failure message is returned on a Windows primary server, although the operation may actually have been successful.
Problem
A NetBackup Web UI catalog recovery message may indicate the operation has failed on a Windows primary server, even though the catalog recovery is actually successful.
Error Message
When the erroneous catalog recovery message is triggered from the Web UI, it fails with an error similar to the message below:
Recovery process failed. You must sign out and restart the NetBackup services. Wait for the services to restart before you sign in again
Cause
While performing the catalog recovery from the Web UI, intermittently a catalog recovery failure message may be shown reflecting the catalog recovery API is failing with permission issues. The OID 495 logs would have log lines showing:
51216-495-3081327626-250715-0000000000.log.gz:0,51216,495,495,90987,1752597882391,1672,390,16:391F644479A86831,13233:SEVERE: [FileNotFoundException] accessing keystore. - C:\Program Files\Veritas\NetBackup\var\global\wsl\credentials\nbwebservice.bcfks
(Access is denied)
at java.base/java.io.FileInputStream.open0(Native Method) at java.base/java.io.FileInputStream.open(Unknown Source) at java.base/java.io.FileInputStream.<init>(Unknown Source) at java.base/java.io.FileInputStream.<init>(Unknown Source)at com.netbackup.common.util.KeyStoreUtils.loadKeyStore(KeyStoreUtils.java:189)
Solution
Check the progress logs to verify that the log lines below are found (typically towards the end of the log file):
11:44:01 INF - Recovery successfully completed
11:44:54 INF - Catalog recovery has completed.
11:44:54 WRN - Passphrase for the disaster recovery package is not set.
You must set the passphrase for the catalog backups to be successful.
11:44:54 WRN - NetBackup will not run scheduled backup jobs until NetBackup is restarted.
11:44:54 WRN - Local or global-level settings that you have configured on the primary server before catalog recovery are overwritten.
It is recommended that you re-configure the required settings after the services are restarted.
This indicates that the catalog recovery was successful, and the failure in the Web UI can be ignored.
Proceed to restart the NetBackup Services, and sign back in to the Web UI.