Resolving Exchange Snapshot Deletion Issues

Article: 100069149
Last Published: 2025-10-10
Ratings: 0 0
Product(s): NetBackup

Problem

Users are unable to delete Exchange snapshots and receive an error message stating that the snapshot is controlled by the backup application. This issue is impacting server capacity utilization.

Error Message

Snapshots were found, but they were outside of your allowed context. Try removing them with the backup application which created them.

Cause

The root cause of this issue is that the Exchange snapshots are being controlled by the NetBackup backup application. This prevents users from manually deleting the snapshots.

Solution

To resolve this issue, follow the steps below:

Step 1: Delete the Shadow Copy Using NetBackup Command-Line Tool

  • Open a command prompt on the affected server.
  • Run the following command to delete the shadow copy using the NetBackup command-line tool:
  • install_path\netbackup\bin\bpfis delete -id snapshot_id

Replace install_path with the current installation path of NetBackup and snapshot_id with the ID of the snapshot you wish to delete.

Step 2: If NetBackup Command Does Not Work

  • Open a command prompt on the affected server.
  • Run the following command to list the existing shadow copies:
  • vssadmin list shadows
  • Identify the shadow copy that is causing the issue.
  • Note the Shadow Copy ID and the Original Volume.

Step 3: Please confirm with your Exchange Administrator before proceeding.

  • Run the following command to delete the shadow copy using DiskShadow:
  • Diskshadow
  • delete shadows all

Step 4: Verify that the shadow copy has been successfully deleted by running the vssadmin list shadows command again.

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