Unable to browse Microsoft 365 backup set "An error occurred while retrieving item-level information from the catalog"

Article: 100055016
Last Published: 2023-03-06
Ratings: 2 0
Product(s): Backup Exec

Problem
 

When browsing a Microsoft 365 backup set, the following message is seen: An error occurred while retrieving item-level information from the catalog.
 

Error Message
 

In the Backup Exec restore wizard the following error message is displayed:
An error occurred while retrieving item-level information from the catalog





SGMON debug log during restore browse shows the following (Backup Exec Management process)


436    MANAGEMENT    2468    2/2/2023 11:39:03 AM    31    02/02 11:39:03.235[MetaData    ] QuerySCFMetaDataAsyncWorker: ConnectionId: 1, QueryName: MDQ_SCFGetTLETypesView
442    MANAGEMENT    2468    2/2/2023 11:39:03 AM    31    02/02 11:39:03.235[MetaData    ] QuerySCFMetaData - MDQ_SCFGetTLETypesView ends with error: 0x2 
actionCode(FailureNoRetry): An error occurred while retrieving item-level information from the catalog. Invalid input parameter for query. : rc=2
443    MANAGEMENT    2468    2/2/2023 11:39:03 AM    31    02/02 11:39:03.235[MetaData    ] QuerySCFMetaData ends: MDQ_SCFGetTLETypesView rc=2 numrows=0
440    MANAGEMENT    2468    2/2/2023 11:39:03 AM    31    02/02 11:39:03.235[MetaData    ] ERROR:SqliteQueryBase:GetFullDBPathFromIncrPit: Invalid Directory path: C:\Program 
Files\Veritas\Backup Exec\\Catalogs\ScfCat\0feed5f5-fc65-4674-ad00-10b477aac109
441    MANAGEMENT    2468    2/2/2023 11:39:03 AM    31    02/02 11:39:03.235[MetaData    ] ERROR:ExecuteParameterizedQuery::Prepare failed Return::2

 

Cause
 

This issue is seen when the catalog location has been changed.
The restore browse operation for Microsoft 365 backup sets is looking in the default catalog location. 
 

Solution

 

There are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time.  However, the issue has been addressed in the revision of the product specified at the end of this article. 
 
Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.

This issue is resolved in Backup Exec 22.1.

 

References

Etrack : 4104674

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