Delay observed for ‘Backup from Snapshot’ and ‘Indexing from Snapshot’ jobs if Snapshot Manager is located on AWS instance with IMDSV2 enabled.

Article: 100053934
Last Published: 2022-09-07
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection, CloudPoint

Problem

'Backup from Snapshot' and 'Indexing from Snapshot' jobs take long time to complete. This duration would take couple of hours to complete, but it may not fail.
NetBackup offers functionality of 'Backup from Snapshot' and 'Indexing from Snapshot' on cloud asset.
'Backup from Snapshot' and 'Indexing from Snapshot' jobs will be in Active state but the transfer rate seems to be stuck at 0 B/sec during initial phase.

 

Error Message

No error

 

Cause

'Backup from Snapshot' and 'Indexing from Snapshot' jobs takes unusually long time to complete if AWS metadata service IMDSv2 has been enabled.  If the AWS instance of Snapshot Manager has been launched with default hop limit of 1 causing AWS API calls to IMDSv2 metadata service to time out.

 

Solution

  • Check the existing HttpPutResponseHopLimit value configured by running the following AWS CLI command:
    • aws ec2 describe-instances --instance-id <instance id> --region <region>
    • Response: Reservations -> Instances -> MetadataOptions -> HttpPutResponseHopLimit
       
  • If IMDSv2 metadata service has been enabled on the AWS instance where Snapshot Manager resides, then it must be reconfigured to use HttpPutResponseHopLimit > 1
    • aws ec2 modify-instance-metadata-options --instance-id <instance id> --region <region> --http-put-response-hop-limit 2

For more information on the IMDSv2 service, refer to Use IMDSv2.

References

Etrack : 4087359

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