Error Code 7653 when logging into the Java Console, after an upgrade to NetBackup 9.1.0.1.

Article: 100052786
Last Published: 2022-07-11
Ratings: 1 2
Product(s): NetBackup & Alta Data Protection

Problem

After an upgrade to NetBackup 9.1.0.1 on Windows Server, Error code 7653 is received when logging into the Java Console.

 

Error Message:

Error Code 7653: The peer host certificate is revoked.

From the install log the Client_Name, host123 is not the name of the server host HOST456.

C:\ProgramData\VERITAS\NetBackup\InstallLogs

NetBackup Install.20220310.130706.log: 03-10-2022,21:45:57 : Performing installation on host: HOST456

NetBackup Install.20220310.130706.log: 03-10-2022,21:55:20 : Client_Name (from registry): host123

 

Cause:

The install log shows that when the Computer name, and the Client_ Name, are not the same, the NBDB adopted the incorrect name.

03-10-2022,17:53:43 : Computer name: HOST456

03-10-2022,17:53:43 : Client_Name (from registry): host123

03-10-2022,17:53:43 : Resolved ASA server name: NB_HOST123

03-10-2022,17:53:43 : Updating server.conf with following line:03-10-2022,17:53:43 : -c 200M -ch 21718M -cl 200M -gd DBA -gk DBA -gl DBA -gna 1 -gp 4096 -k -m -n NB_HOST123 -o "C:\Program Files\Veritas\NetBackupDB\log\server.log" -os 1M -ti 0 -wc- -x tcpip(LocalOnly=YES;ServerPort=13785)


Secondly, the two names are mapped but the mapping doesn't correct or compensate for the condition.

C:\Program Files\Veritas\NetBackup\bin\admincmd>nbhostmgmt.exe -list -short

Host ID Mapped Names
a89c754f-cax1-4268-a388-d17ca1e6223f host123 host456 host123

 

Solution:

The solution takes many steps.

1. Change the CLIENT_NAME in the registry to the correct host, host456.
2. Change the NB_HOST123 to NB_HOST456 in C:\Program Files\Veritas\NetBackupDB\CONF\server.conf.
3. Change the NB_host123 to NB_host456 in C:\Program Files\Veritas\NetBackupDB\data\vxdbms.conf.
4. Update the hostid to the new host, add the correct mapping and remove the incorrect name.

From Admin command prompt:
cd C:\Program Files\Veritas\NetBackup\bin\admincmd

nbhostmgmt -updatehost -hostid a89c754f-cax1-4268-a388-d17ca1e6223f -newhostname host456
nbhostmgmt -add -hostid a89c754f-cax1-4268-a388-d17ca1e6223f -mappingname host456.fqdn
nbhostmgmt -delete -hostid a89c754f-cax1-4268-a388-d17ca1e6223f -mappingname host123

5. Cycle the NetBackup Services.
6. Renew the host ID certificate for the host.

From Admin command prompt:
C:\Program Files\Veritas\NetBackup\bin>nbcertcmd -getcertificate -force

If it fails, review the certmapinfo.json file to see if there are certificates from any other domains (other trusted primary servers), then either delete the file if only one stanza is present or edit out the stanza for the local host, then obtain a reissue token and reissue the certificate.

 

References

Etrack : 4069990

Was this content helpful?