Problem
Async Snapshot – NetBackup support for the new asynchronous snapshot support added by Microsoft.
Error Message
Backup failure with snapshot error messages.
Cause
- Snapshot Issue - Azure Stack offers page blob snapshot APIs consistent with Azure. In Azure Stack, each page blob is implemented as a VHD file. While taking the snapshot it is observed that snapshot is taking long time for large and highly fragmented page blobs or vhds. In such a situation, the snapshot causes VM I/O stalls within the guest leading to an application crash (e.g. SQL) or kernel panic (Linux) and causes snapshot API timeout. Due to this the backups fail in some cases.
- Fixed Issue with fetching storage account keys - We have observed some change in the API response value. This can cause backups to fail with the released plug-in.
Solution
A supported Emergency Engineering Binary (EEB) has been made available for this issue. Contact Veritas Technical Support to obtain this fix referencing this article and Etrack 4003351. This EEB has not yet gone through extensive QA testing so if you are not adversely affected by this problem and have a satisfactory working plug-in in place, we recommend that you wait for the new public release of the plug-in.
Veritas Technologies LLC currently addresses these issues by way of an EEB to the current version of the software.
Contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.
To fix the snapshot issue, Microsoft has done some improvements and added async support in the snapshot method. This can take a long time for large and highly fragmented page blobs, but snapshots get resolved.
For fetching storage account keys changes we have updated the plug-in, so that backups work on Azure Stack 2002 version.