Unable to connect to hosts which have more than 64 IP addresses configured 'status: 25: cannot connect on socket'
Problem
Following the upgrade to Windows host which has more than 64 assigned IP addresses configured, at NetBackup versions 8.1.2. or 8.2 you will encounter a communication error '25: cannot connect on socket'
Error Message
A backup to that host will start to exhibit the following errors, from the NetBackup details status of the job.
Error bpbrm cannot execute cmd on client
Info bpbkar done. status: 25: cannot connect on socket
bpcd log extract on the client will report the following:
<2> vnet_registerPBXServer: ../../libvlibs/vnet_pbx.c.119: pbxRegisterExEx failed with error 0:The operation completed successfully.
<2> daemon_select_and_accept_ex: vnet_registerPBXServer() failed: 47
<2> vnet_registerPBXServer: ../../libvlibs/vnet_pbx.c.119: pbxRegisterExEx failed with error 0:The operation completed s not uccessfully.
<2> daemon_select_and_accept_ex: vnet_registerPBXServer() failed: 47
<2> vnet_registerPBXServer: ../../libvlibs/vnet_pbx.c.119: pbxRegisterExEx failed with error 0:The operation completed successfully.
PBX log extract on the client will report the following:
[Application] VxICS 50936 103 PID:10848 TID:4492 File ID:103 [No context] [Info] PBX_Manager:: handle_input with fd = 0x2d4
[Application] VxICS 50936 103 PID:10848 TID:4492 File ID:103 [No context] [Info] Context init done 127.0.0.1 [22852->1556]
[Application] VxICS 50936 103 PID:10848 TID:4492 File ID:103 [No context] [Info] PBX_Manager::handle_input, peer fd = 0x2ec, From 127.0.0.1, Port 22852
[Application] VxICS 50936 103 PID:10848 TID:4492 File ID:103 [No context] [Info] PBX_Client_Proxy::parse_line, line = port=what From 127.0.0.1 [22852->1556]
[Application] VxICS 50936 103 PID:10848 TID:4492 File ID:103 [No context] [Info] Sending port number 19094 [22852->1556]
[Application] VxICS 50936 103 PID:10848 TID:4492 File ID:103 [No context] [Info] PBX_Client_Proxy::handle_close Closing client proxy for 127.0.0.1 [22852->1556]
And when attempting to connect to the host using bptestbpcd, it will fail and respond with the following error:<2> vnet_pbxConnect_ex: pbxConnectExEx() failed: 131
<2> vnet_pbxConnect_ex: ../../libvlibs/vnet_pbx.c.699: pbxSetAddrEx/pbxConnectExEx return error 131:Connection reset by peer
<8> do_pbx_service: [vnet_connect.c:3420] vnet_pbxConnect() failed, status=18, errno=2, use_vnetd=1, cr->vcr_service=vnetd
<2> vnet_proxy_get_logs: fstat(6) failed: 9
Cause
NetBackup versions 8.1.2 and 8.2 only support 64 IP addresses configured on a host.
Solution
An Engineering Binaries fix is available for NetBackup version 8.2 allowing upto 260 IP addresses that can be assigned to a Windows host.
Alternatively, reduce the number of assigned IP addresses running on a Windows host to 64 or less.
Please contact Veritas NetBackup Support and request the Engineering Binaries (EEB) 3996724 and 3994065
A patch has been made available for this issue. This patch has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix. Please contact Veritas Technical Support to obtain this patch.