Install or Upgrade of Veritas System Recovery Management Solution (VSR-MS) fails with 'Data at the root level is invalid'.
Problem
Installation or upgrade of Veritas System Recovery Management Solution (VSR-MS) fails part-way through due to the error shown below:
Error Message
A critical error occurred:
System.Xml.XmlException: Data at the root level is invalid. Line 16, position 1.
Cause
Unknown at this stage.
Solution
Perform the following steps in this order on the SMP/VSR-MS server:
- End the current installation/upgrade and close Symantec Installation Manager (SIM)
- Run CMD as administrator
- Change into the following directory: \Program Files\Altiris\Notification Server\Bin
- Run the following command: AeXConfig.exe /configure "C:\Program Files\Altiris\Veritas System Recovery Management Solution\Config\Symantec_BackupSln.config"
- Wait for command to complete (when complete, CMD will be returned to a blinking cursor)
- Run the following command: AeXConfig.exe /configure "C:\Program Files\Altiris\Veritas System Recovery Management Solution\Config\BackupSlnLP.config"
- Wait for command to complete (when complete, CMD will be returned to a blinking cursor)
NOTE: Depending on the size of environment, these commands may take several hours to finish. It's important that the command if left to finish and NOT interrupted when it's running.
If you are using the VSR-MS Linux Management Solution (only required when managing Linux Servers), the following steps are also required:
- Run CMD as administrator
- Change into the following directory: \Program Files\Altiris\Notification Server\Bin
- Run the following command: AeXConfig.exe /configure "C:\Program Files\Altiris\Veritas System Recovery Linux Management Solution\Config\BESRLSolution.config"
- Wait for command to complete (when complete, CMD will be returned to a blinking cursor)
- Run the following command: AeXConfig.exe /configure "C:\Program Files\Altiris\Veritas System Recovery Linux Management Solution\Config\BESRLLanguagePack.config"
- Wait for command to complete (when complete, CMD will be returned to a blinking cursor)
The VSR-MS console should now be functional and accessible. If further assistance is required, please contact Veritas Technical Support: https://www.veritas.com/support/en_US/contact-us.html