Problem
After a full disk during the NetBackup installation or upgrade, NetBackup 8.0 or above can experience issues where the Web Service machine certificate for the NetBackup service communication may not be created. The same problems could occur if the NetBackup filesystem is damaged and the certificates are lost of corrupted.
In this case the authentication Host ID and Hostname certificates are valid and normal operations continue. The Web Service error is seen when accessing the NetBackup GUI, and the ' Security Events ' option is not available until the issue is resolved.
Error Message
Status Code:160Web service authentication failed.
Note: There is no space between '160' and 'Web', as the screen shot below confirms.
However, in other instances, a popup may be received which shows the following error:
Status Code: 160
Web service authentication failed. You may
have to log in to the NetBackup Administrator
Console again.
Cause
The master server had the inability to generate the Web Service machine certificate for NetBackup service communication.
Solution
To manually generate the web service machine certificate, perform the following steps.
UNIX/Linux:
1) Log in into the master, then change directory and delete/move the current invalid certificate.# cd /usr/openv/var/global/vxss/websvccreds/credentials
# rm -i <master_name>
2) Web Service stopped and restarted.# /usr/openv/netbackup/bin/nbwmc stop
# /usr/openv/netbackup/bin/nbwmc start
3) Checked the Web Service (nbwmc) is running now.# /usr/openv/netbackup/bin/bpps -x | grep -i nbwmc
4) Recreated the missing certificate# /usr/openv/netbackup/bin/admincmd/nbcertconfig -m -user <web service user>
5) Checked the certificate is generated (this can be viewed as it's an Ascii file).
6) Started the Java GUI and ensured the Web Service warning message has gone and the ' Security Events ' option can now be accessed.
Windows:
1) Log in into the master, then change directory and delete/move the current invalid certificate.cd <installPath>\NetBackup\var\global\vxss\websvccreds\credentials
del <master_name>
2) Web Service stopped and restarted.<installPath>\NetBackup\wmc\bin\nbwmc.exe -stop -srvname "NetBackup Web Management Console"
<installPath>\NetBackup\wmc\bin\nbwmc.exe -start -srvname "NetBackup Web Management Console"
3) Checked the Web Service (nbwmc) is running now.<installPath>\NetBackup\bin\bpps | findstr nbwmc
4) Recreated the missing certificate<Install path>\netbackup\bin\admincmd\nbcertconfig.exe -m -user <web service user>
5) Checked the certificate is generated (this can be viewed as it's an Ascii file).
6) Started the Java GUI and ensured the Web Service warning message has gone and the ' Security Events ' option can now be accessed.
Note 1: Workarounds would include a full reconfigure of the secure communications following all the steps which can be obtained from Veritas Support, or re-installing NetBackup.
Note 2: The error has been known to occur if the NetBackup Base license is missing also.