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Article: 100034019
Last Published: 2017-05-09
Ratings: 0 1
Product(s): NetBackup & Alta Data Protection
Problem
Backups may fail intermittently.Error Message
From Activity Monitor:1: (4200) Operation failed: Unable to acquire snapshot lock
From job details:
19:34:59.081 [10984.20696] <4> bpfis: parameter client_type 39, fis_accl 0, fis_accl_cksv -1, SNAPSHOT_IS_HERE 1
19:34:59.081 [10984.20696] <4> bpfis: Volume guid list is empty, will not pause and flush NetBackup Change Journal databases
19:34:59.081 [10984.20696] <4> bpfis main: read_registry_dw_value for VSS_CONCURRENT_OPERATIONS: return status 2, return value 0
<note the 1 hour delay here>
20:34:59.088 [10984.20696] <16> bpfis main: Failed to get VSS Snapshot Mutex lock!!
20:34:59.104 [10984.20696] <4> bpfis: INF - Thawing R:\ using snapshot method VSS.
20:34:59.104 [10984.20696] <8> bpfis: WRN - R:\ is not frozen
20:34:59.104 [10984.20696] <4> bpfis: INF - Thawing Q:\ using snapshot method VSS.
20:34:59.104 [10984.20696] <8> bpfis: WRN - Q:\ is not frozen
20:34:59.135 [10984.20696] <8> bpfis: WRN - snapshot delete returned status 20
20:34:59.166 [10984.20696] <4> bpfis: Starting keep alive thread.
20:34:59.166 [10984.20696] <4> bpfis: INF - EXIT STATUS 4200: Operation failed: Unable to acquire snapshot lock
Cause
Microsoft Volume Shadow Copy Service (VSS) snapshot operations are serialized. If a snapshot for a given disk is already taking place new snapshot requests for that disk will be unable to execute until the previous snapshot releases its lock. This is the source of the messages:<16> bpfis main: Failed to get VSS Snapshot Mutex lock!!
and
<4> bpfis: INF - EXIT STATUS 4200: Operation failed: Unable to acquire snapshot lock
In the job details above we see there is a one hour delay from 19:34:59.081 to 20:34:59.088.
This is due to the snapshot timer default of 3600000 microseconds (60 minutes).
Solution
On the failing client do the following:1. Make a backup copy of the registry in case any mistakes are made in the steps below.
2. Open the registry using regedit.
3. Navigate to this path in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\VERITAS\NetBackup\CurrentVersion\Config\
4. Check if the following value exists:
VssOperationMutexLockTimeout
5. If not, create a new dword 32-bit value named:
VssOperationMutexLockTimeout
The path will now be:
HKEY_LOCAL_MACHINE\SOFTWARE\VERITAS\NetBackup\CurrentVersion\Config\VssOperationMutexLockTimeout
6. Set "VssOperationMutexLockTimeout" to:
7200000 (decimal)
This value is set in microsends, here are some sample settings:
7200000 (120 minutes)
5400000 (90 minutes)
3600000 (60 minutes - the default when not set)
7. Once this change has been made monitor the backups to confirm this resolves the issue.