Enterprise Vault Office Mail App doesn't work for items in the mailboxes of secondary email accounts.

Article: 100033438
Last Published: 2016-12-21
Ratings: 1 0
Product(s): Enterprise Vault

Problem

Enterprise Vault Office Mail App (OMA) doesn't work for items in the mailboxes of secondary email accounts.

From Outlook client application, user can add shared email folders of other user's email accounts by modifying [Account Settings]->[More Settings]->[Advanced] and [Add] the other user's mailbox to [Open additional mailboxes] list.
For example, if a user (let's say "User1") added the secondary email account (let's say "User2")'s mailbox, User1 can access to the email in User2's mailbox based on the configured Exchange mailbox access permission.
In case there are some Enterprise Vault shortcuts in User2's mailbox, User1 can open these shortcuts from Outlook client if User1 has enough Enterprise Vault privilege to User2's archive.

Like as Outlook client, from Outlook Web App (OWA), user can add shared email folders of other user's email accounts by right click in tree pane and use [Add shared folder] menu.
Assume User1 added User2's mailbox, similar to Outlook client case explained above.
User1 can access to the email in User2's mailbox based on the configured Exchange mailbox access permission.
If the version of Exchange server is 2013 or later, User1 need to use Enterprise Vault Office Mail App (OMA) to open Enterprise Vault shortcuts. If there are some Enterprise Vault shortcuts in User2's mailbox and User1 want to open these shortcuts from OWA, User1 need to open Enterprise Vault Office Mail App (OMA) first. But it fails with message "Archived status of this item is unavailable.", even User1 has enough Exchange permissions and Enterprise Vault privileges to User2's Exchange mailbox and User2's Enterprise Vault archive.

 

Error Message

Archived status of this item is unavailable.

 

Cause

Some OMA API Microsoft provided including makeEwsRequestAsync() doesn't allow OMA applications to access mailboxes in the secondary email accounts.

 

Solution

This is limitation cause by Microsoft's Office Mail App (OMA) security context design.

References

Etrack : 3905357

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