Problem
When EV Collection (Cabinet) files have been migrated to a NetApp AltaVault device the items can no longer be retrieved. The user receives a message stating that the item is no longer in the vault.
Error Message
A DTRACE of the StorageOnlineOPNS process will reveal the following information:
{CMigratorHelper::ExtractFromCab} (Entry)
{CCabinet::ExtractFromCab} (Entry)
{CCabinet::ExtractFromCab:#271} Failed to extract files <files><f>2016\07-27\6\027\602703A47852BF02C9800FCD384D0EC1.DVS</f></files>| from Collection file \\AltaVaultDevice\AltaVaultShare\migrationfolder\2016\07-27\6\Collection12345.cab. Extract Operation = 0, hr = 0x80070002, FDI Error =
{CCabinet::ExtractFromCab} (Exit) Status: [The system cannot find the file specified. (0x80070002)]
{CNTFSStorageDeviceReader::LoadCollectedFile:#393} _com_error exception: [The system cannot find the file specified. (0x80070002)]
The Enterprise Vault Event log will show:
Event ID: 6882 Unable to complete retrieval request
Reason: The system cannot find the file specified. (0x80070002)
Vault Id: 160D23CDD90DE754CBFC8BE5D300108801110000evalias
Item Id: 201607279610586~201403182114050000~Z~602703A47852BF02C9800FCD384D0EC1
Reference: Vault/RI
If the item that cannot be found is a SISPart then the following will be logged:
Event ID: 6882 Unable to complete retrieval request
Reason: Could not find the sis part corresponding to input attachment identifier.
Vault: %FolderName%
Vault Id: 1C7953552017F754D8D45CEBA0DF601171110000evalias
Item Id: 201610116187897~201310110308350000~Z~801B4744FDA243226F98A3CA4A36BF81
Reference: Vault/RI
Cause
This is due to the NetApp AltaVault device being a case sensitive device. When cabinet files are created on an Enterprise Vault partition they are created with the file extension .CAB in an upper case format. Enterprise Vault is not a case sensitive application and in this instance the request to obtain the cabinet file is initiated with the cabinet file extension in a lower case format. The Alta Vault device does not accept this request and the file not found is the given response.
Solution
This issue has been addressed in the following release:
Enterprise Vault 12.1.2 Release
http://www.veritas.com/docs/000125196