Oracle backup is failing with "unexpected error" when the database parameter "backup_tape_io_slaves" is set to "true".

Article: 100031495
Last Published: 2024-02-01
Ratings: 0 0
Product(s): Backup Exec

Problem

Backup Exec Oracle agent backup fails with "unexpected error" when the following database parameter "backup_tape_io_slaves" is set to "true".

The default value for this Oracle database parameter is "false".
With the default parameter value, all backup/restore operations are successful.

 

Error Message

For DBA initiated backup/restore operations:

The job will not get submitted to the Backup Exec Media Server and the console will report the following error message:

 
"Unexpected error".

For Backup Exec Media Server initiated backup/restore operations:

The job will report the following error message as part of the job log:

 
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on ch0 channel at 10/29/2015 10:45:14
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27023: skgfqsbi: media manager protocol error
ORA-19511: Error received from media manager layer, error text:
   BEError(0xe0001005) Backup Exec encountered an unexpected error.

Completed status: Failed Final error: 0xe0001005 - Backup Exec encountered an unexpected error.
Final error category: Resource Errors
For additional information regarding this error refer to link V-79-57344-4101

 

Cause

This issue is seen when the following Oracle database parameter "backup_tape_io_slaves"  has been changed from the default value of "FALSE" to "TRUE".
 

Solution

To check the value of 'backup_tape_io_slaves' parameter of the Oracle database, execute the following command:
 
Please open a SQLPLUS session and logon with SYSDBA privilege.
SQL> show parameter backup_tape_io_slaves;

Example:
NAME                              TYPE          VALUE
--------------------------------      -----------      -----------------
backup_tape_io_slaves      boolean       FALSE
 


To change the parameter for 'backup_tape_io_slaves' execute one of the following commands depending on your Oracle configuration.

IMPORTANT: Please clarify with the Oracle DBA that this parameter can be changed and which command should be run.

Please open a SQLPLUS session and logon with SYSDBA privilege.

To have the change taking effect after a database restart:
---------------------------------------------------------------------------------
a) with SPFILE (server parameter file, binary):
alter system set backup_tape_io_slaves=false scope=spfile;

b) with PFILE (plain-text parameter file):
Set the parameter backup_tape_io_slaves to false in init<ORACLE_SID>.ora file.


To have the change taking effect for new sessions (restart not required):
-------------------------------------------------------------------------------------------------
a) with SPFILE (server parameter file, binary):
alter system set backup_tape_io_slaves=false deferred scope=both;

b) with PFILE (plain-text parameter file):
Set the parameter backup_tape_io_slaves to false in init<ORACLE_SID>.ora file.
alter system set backup_tape_io_slaves=false deferred scope=memory;


Note:
This change may result in a minor impact on database backup performance.
 

Veritas Technologies LLC has acknowledged that the above-mentioned issue is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers.
 
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see https://www.veritas.com
 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

References

Etrack : 3818121

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