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Problem
Unable to reset the NBAZDB database password when removing NBAC configuration in NetBackup,
Error Message
C:\Program Files\Veritas\NetBackup\bin>nbdb_admin -dba nbusql command fails to complete.
Change of dba password for NBDB successful.
Change of dba password for NBAZDB failed.
Cause
ODBC connection to NBAZDB fails.
install_path\NetBackup\logs\nbdb\ log shows
16:22:08.562 [3216.4912] <4> nbdb_admin: Change of dba password for NBDB successful.
16:22:08.562 [3216.4912] <4> secure_db: Entering.
16:22:08.656 [3216.4912] <16> secure_db: ODBC connection failed.
16:22:08.656 [3216.4912] <16> secure_db: ErrMsg [Sybase][ODBC Driver][SQL Anywhere]Invalid user ID or password, ErrCode -1, Sqlstate 28000
16:22:08.671 [3216.4912] <4> secure_db: Exiting with rc = 25
16:22:08.671 [3216.4912] <16> nbdb_admin: Change of dba password for NBAZDB failed.
16:22:08.671 [3216.4912] <4> nbdb_admin: Exiting with rc = 25
Solution
First confirm this entry with correct path is in the \VERITAS\NetBackupDB\CONF\databases.conf file
"C:\Program Files\Veritas\NetBackupDB\data\NBAZDB.db" -n NBAZDB
If missing, add it and try the password reset again:
\VERITAS\NetBackup\bin and run nbdb_admin.exe -dba <password> (NBU default password = nbusql)
If still failing, replace the NBAZDB.db.template with a new template file:
1. Stop NetBackup services again
bpdown.exe -v -f
2. Repeat these steps from 000016511 to clean up AZ data
rename ...\VERITAS\NetBackupDB\data\NBAZDB.db to NBAZDB_old.db2
rename ...\VERITAS\NetBackupDB\data\NBAZDB.log to NBAZDB_old.log2
delete the AZ_DB_PASSWORD row from ...\VERITAS\NetBackupDB\data\vxdbms.conf
3. Use a different NBAZDB.db.template file from a new non-configured install of the same NetBackup version, or from an earlier backup copy.
copy from ...\VERITAS\NetBackupDB\data\NBAZDB.db.template to ...\VERITAS\NetBackupDB\data\NBAZDB.db
4. Generate a new Database and Change Log again
Note: NBU Services need to be stopped for this step to succeed
Note: Omit the -q switch to see the success or failure of the command on-screen
cd into ...\VERITAS\NetBackup\bin and run: "C:\Program Files\VERITAS\NetBackupDB\Win64\dblog.exe" -q -t NBAZDB.log "C:\Program Files\VERITAS\NetBackupDB\data\NBAZDB.db" (Change "C:\Program Files" to the correct path for your environment)
5. Start NBU services
bpup -v -f
6. Reset the database password:
cd into ...\VERITAS\NetBackup\bin and run nbdb_admin.exe -dba <password> (NBU default password = nbusql)
7. Start NBU services again.
bpup -v -f
Test a NetBackup Catalog Backup to confirm.