Install of NetBackup rolls back when attempting to register VirtFile.sys

Article: 100014885
Last Published: 2015-01-28
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

When attempting to perform a local install of NetBackup, the install fails and a roll-back occurs.

 

Error Message

01-15-2015,11:21:08 :  DIFXAPP: INFO: 'Component' is 'VirtFile.inf.A622993E_E091_4837_882C_A7795920ECAF'

01-15-2015,11:21:08 :  DIFXAPP: INFO: Component state 0x2 -> 0x3
01-15-2015,11:21:08 :  DIFXAPP: INFO: 'ComponentId' is {24B4B1C2-B6AD-4690-8455-DB29A706DCE1}
01-15-2015,11:21:08 :  DIFXAPP: INFO: 'Flags' is 12
01-15-2015,11:21:08 :  DIFXAPP: INFO: component path is C:\Program Files\VERITAS\NetBackup\bin\VirtFile\
01-15-2015,11:21:08 :  DIFXAPP: INFO: user SID of user performing the install is ' S-1-5-21-2868661422-111858062-2720777649-1002'.
01-15-2015,11:21:08 :  DIFXAPP: INFO: creating HKEY_USERS\S-1-5-21-2868661422-111858062-2720777649-1002\Software\Microsoft\Windows\CurrentVersion\DIFxApp\Components\{24B4B1C2-B6AD-4690-8455-DB29A706DCE1} (User's SID: 'S-1-5-21-2868661422-111858062-2720777649-1002') ...
01-15-2015,11:21:08 :  DIFXAPP: ERROR 0x57 encountered while creating subkey for component '{24B4B1C2-B6AD-4690-8455-DB29A706DCE1}'
01-15-2015,11:21:08 :  DIFXAPP: RETURN: ProcessDriverPackages() 87 ( 0x57)
01-15-2015,11:21:08 :   CustomAction MsiProcessDrivers returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
01-15-2015,11:21:08 :  Action ended 11:21:08: MsiProcessDrivers. Return value 3.
01-15-2015,11:21:09 :  Action ended 11:21:09: INSTALL. Return value 3.
 

Cause

The installation of NetBackup depends on Windows Installer's MsiProcessDrivers function.

When MsiProcessDrivers attempts to register the VirtFile.sys driver, it attempts to create temporary items in the HKEY_USERS\<SID> folder of the user credentials used to perform the installation.

If a CMD window is spawned without linking a Windows Profile, the CMD window will neither create a HKEY_USERS\<SID> registry key (if non-existant) or link to an existing HKEY_USERS\<SID> registry key.   As such, when the Windows Installer sequence attempts to create content in this registry structure, it will be unable to.

 

Example:
1. RDP into the intended NetBackup Client machine (the credentials used to establish this RDP session do not require Local Administrator permissions)
2. Open a CMD prompt
3. Issue this command to open a new CMD window with Local Administrator level permissions:  runas /noprofile /user:<admin user> cmd.exe
4. From within the new CMD window, install NetBackup using either setup.exe or silentclient.cmd
5. Observe an install failure as documented above


The failure occurs because the new CMD prompt created in Step 3 does not link to a Windows Profile due to the "/noprofile" switch included in the command syntax used to generate the new CMD window.

Solution

Because the Microsoft function 'MsiProcessDrivers' requires the use of a Windows Profile, avoid opening a CMD window which is unlinked to a Windows Profile.  Adjust the 'runas' syntax to omit the "/noprofile" switch.

By default the 'runas' command attempts to link a Windows Profile to the command executed:
Example: runas /user:<admin user> cmd.exe

Alternately, you could include a "/profile" switch in the 'runas' syntax:
Example: runas /profile /user:<admin user> cmd.exe

 

Workarounds

  • If you are using a 3rd party software distribution tool which does NOT create/link a Windows Profile upon authentication, you will encounter this issue.  Talk to the tool vendor to see if the tool can be altered to allow use of a Windows Profile.
  • Use the NetBackup GUI Installer from a remote host and select the option to "Install to multiple computers on your network".  This option will produce the needed Windows Profile during install.
  • Use NetBackup LiveUpdate to install NetBackup to network attached clients.  This option will produce the needed Windows Profile during install.

Applies To

This has been observed while installing NetBackup 7.5 and 7.6..x.x.

A similar issue has been documented for push installations in 000018947 - Remote push install of NetBackup 7.5.0.6 client fails to Windows 2012.

However, this has also been observed when performing a local install using either setup.exe or silentclient.cmd or when having a 3rd party software distribution tool install NetBackup.

Was this content helpful?