Index Service fails to start with Event ID 41293 error: 8000401a

Article: 100011350
Last Published: 2019-12-09
Ratings: 0 1
Product(s): Enterprise Vault

Problem

Enterprise Vault Indexing Service fails to start and Event 41293 : 8000401a

Error Message

Dtrace Information:
To validate if this is the issue, a Dtrace is needed, please perform the following steps on the Enterprise Vault (EV) server while re-creating the issue.

  • For more information about Enterprise Vault’s Dtrace Utility please see 100038975
  • Dtrace the process EVIndexAdminService for no less than 5 minutes while re-creating the issue.
  • Open the log file created and search for either of the following the strings:

(EVIndexAdminService)      <3612>  EV-H        {INDEXBROKER_DCOMSERVER.EN_US} Exception: Retrieving the COM class factory for component with CLSID {EB0F5829-7144-4978-9C14-AEE8EC8E7249} failed due to the following error: 8000401a. Info: Diag:HRESULT: 8000401a Type:System.Runtime.InteropServices.COMException ST:   at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)|   at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)|   at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)|   at System.Activator.CreateInstance(Type type, Boolean nonPublic)|   at Symantec.EnterpriseVault.Common.DCOMServerFactory.CoCreate()|   at Symantec.EnterpriseVault.Common.DCOMServerManager.Start() Inner:None
(EVIndexAdminService)      <3612>  EV-L        {CHILDPROCESSMANAGERBASE.EN_US} Error [-21474672388X] is not unrecoverable
 (EVIndexAdminService)      <3612>  EV~E       |Event ID: 41293 An unexpected error has occurred.|Error Summary: Indexing Service start up error |Error Details: Retrieving the COM class factory for component with CLSID {EB0F5829-7144-4978-9C14-AEE8EC8E7249} failed due to the following error: 8000401a. |

 

Cause

0x8000401a refers to CO_E_RUNAS_LOGON_FAILURE
EB0F5829-7144-4978-9C14-AEE8EC8E7249 CLSID points to IndexBroker.

Solution

This issue can be resolved by performing one of the following options:

  1. Re-enter the Vault Service Account (VSA) credentials (Username & password) in Vault Admin Console (VAC) >> Directory Properties and restart the EV Admin Service
     
  2. Add the VSA account under - Dcomcnfg > Dcom Configuration > Indexbroker Properties > Identity > This user and reboot the EV Server.

Was this content helpful?