Browsing and backup of Exchange databases fails with error "Backup Exec could not back up the Exchange database because it could not find a healthy copy of the database"

Article: 100010815
Last Published: 2020-07-10
Ratings: 2 2
Product(s): Backup Exec

Problem

Browsing and backup of Exchange 2010 or later databases in backup job fails with error "Backup Exec could not back up the Exchange database because it could not find a healthy copy of the database". Backup if performed fails with error "Final error: 0xe0000391 - Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found, however. Update the selection list and run the job again."

Error Message

Error while Browsing Exchange databases in backup selection:

Note : This error appears while expanding Information Store and highlight the database from left pane of selection window.

Error in the failed Backup Job Log:

Final error: 0xe0000391 - Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found, however. Update the selection list and run the job again.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-913

UMI Code: V79-57344-897 : 0xE0000381 - Backup Exec cannot find a working copy of the Exchange database on any members of the Database Availability Group (DAG). Ensure that the database copies are not corrupt and that there are not hardware-related issues.  Check your backup selections or preferred server configuration, and then run the job again.

Error 1 in the debug on Exchange server:
This error indicates that backup exec remote agent could not get database information.

BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\shared] - EseProcess::Init: OpenThreadToken successful
BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\shared] - ESE07 process not ready
BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\shared] - ESE07, failed to set options, 0x80004005
BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\ese] - [EseE14::GetTargetDatabaseCopyStatus] machine:WINDOWS2012 database:Mailbox Database 1999579866 targetSite:null options:0x8 flags:0 count:0
BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\shared] - ESE07 process not ready
BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\ese] - Error (0x80004005) !!! EseE14::GetTargetDatabaseCopyStatus("WINDOWS2012", "Mailbox Database 1999579866") failed
BEREMOTE: [10/07/13 09:24:09] [6728]  [fsys\ese] - [ESE_AttachToDLE] Fail to get database copy information. Abort the backup (0xe000038d) !!!!!
BEREMOTE: [10/07/13 09:24:09] [6728]  [ndmp\ndmpsrvr] - DSEnumerator failed with -536870003: Backup Exec could not back up the Exchange database because it could not find a healthy copy of the database.

Error 2 in the debug on Exchange server:
This error indicate sub program, monad.exe, to get database information failed to load .Net library.

BEREMOTE: [12/02/19 14:33:12] [8860]  [fsys\shared]        - Monad RPC timeout 300000
BEREMOTE: [12/02/19 14:33:12] [8860]  [fsys\shared]        - EseProcess::Init: OpenThreadToken successful
BEREMOTE: [12/02/19 14:33:12] [8860]  [fsys\shared]        - EseProcess::Init: WhoAmI - domain\administrator
UNKNOWN:  [12/02/19 14:33:12] [0000]  BECRYPTO Base Address is BE00000
UNKNOWN:  [12/02/19 14:33:12] [0000]  BECryptoInit: Initialized locks for SSL callbacks
UNKNOWN:  [12/02/19 14:33:12] [0000]  BECryptoInit: BECrypto non-FIPS mode successfully enabled.
UNKNOWN:  [12/02/19 14:33:12] [0000]  Did not find HKLM\Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Exchange\PowerShellOptions using default 8
UNKNOWN:  [12/02/19 14:33:12] [0000]  Did not find HKLM\Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Exchange\PassiveSelectionOptions using default 0
UNKNOWN:  [12/02/19 14:33:12] [0000]  ClrCreateManagedInstance Failed hr = 80131700

 

Cause

This issue will come up if monad.exe.config file is missing from X:\Program Files\Veritas\Backup Exec\RAWS directory on Exchange server

Note: X:\ is the volume where Backup Exec Remote Agent is installed.

If the Backup Exec Remote Agent service in the Exchange server is not configured to Log on as Local System Account.

Solution

If monad.exe.config file has been renamed or has been quarantined by anti-virus software then renaming/restoring back the file will fix the issue. Monad.exe.config.rename file might exist in the Backup Exec Remote Agent install folder. If monad.exe.config.rename file exists, change the file name to monad.exe.config. If the file is not found then uninstalling Backup Exec Remote Agent from Exchange server and then re-installing the Remote Agent will bring back the file.

If the Backup Exec Remote Agent service in the Exchange server is configured with any Domain User Account, please change the Logon account to use Local System Account, from Windows Services (services.msc) console, and restart the service. Backup Exec Remote Agent service must be running using Local System Account.

 

 

References

UMI : V-79-57344-913

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