Remote Simplified Disaster Recovery (Remote SDR) doesn't proceed when Direct access sharing is enabled for the restored server.
Problem
Remote Simplified Disaster Recovery (Remote SDR) doesn't proceed when Direct access sharing (alias Client-side deduplication) is enabled for the restored server.
Job status "Loading Media" and "Queued" are repeatedly displayed on the Backup Exec console.
Error Message
Adamm.log displays the information as below.
[7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
[7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
[7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
[7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
[7636] PvlDrive::DisableAccess() - ReserveDevice failed
Drive = 1031 "DedupeStorage001:20"
ERROR = 0x0000001F (ERROR_GEN_FAILURE) ->E_PVL_ERROR_PATH_NOT_FOUND
SGMon debug log on Backup Exec server displays the information as below regarding PVLSVR
PVLSVR: [7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
PVLSVR: [7636] DeviceIo: ndmpConnect: connection=0x000000000BEC01B8 host=BE2K12RA0002 port=10000
PVLSVR: [7636] DeviceIo: ndmpConnect: socket=0x630, local=10.193.82.116:52007, family=2 <-> peer=10.193.82.116:10000, family=2
PVLSVR: [7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
PVLSVR: [7636] DeviceIo: ndmpConnect: connection=0x000000000BEC01B8 host=BE2K12RA0002 port=10000
PVLSVR: [7636] DeviceIo: ndmpConnect: socket=0x61c, local=10.193.82.116:52008, family=2 <-> peer=10.193.82.116:10000, family=2
PVLSVR: [7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
PVLSVR: [7636] DeviceIo: 02:00:20:00 - NDMP device not connected or reservation conflict, SCSI cmd 00
PVLSVR: [7636] AdammSession::Execute( ADAMM_SESSION_EXECUTE_MOVER_MOUNT_SPECIFIC )
Session = {60259326-BB71-4A2C-8BE3-F148BCC45783}
ERROR = 0xE000810C (E_PVL_DRIVE_NOT_AVAILABLE)
Cause
This issue can occur in the environment if direct access sharing of deduplication disk storage is enabled for the remote server.
Solution
Before attempting to start the SDR restore of a remote computer that was backed up to a deduplication disk storage, perform the following procedure.
1. Open Backup Exec console.
2. Double-click the restored server in "Backup and Restore" view.
3. Select "Direct access sharing" and uncheck the checkbox.
4. Restart all Backup Exec services.
5. Start the remote SDR restore process.
Note: After this issue has occurred, restarting Backup Exec services on Backup Exec server disables direct access sharing because the restored server doesn't exist during the remote SDR.
Applies To
Any versions of Backup Exec
Remote SDR
Deduplication disk storage
Direct access sharing for Client-side deduplicaiton