Problem
No status of the jobs in the activity monitor, happening for both User and schedule backup.
Error Message
N/A: The Activity Monitor is blank in the Administration Console.
Cause
The jobid file is empty.
Unix/Linux: /usr/openv/netbackup/db/jobs/jobid
Windows: install_path\Veritas\NetBackup\db\jobs\jobid
Solution
Need to rebuild the jobid file.
- Check the last jobid from the activity monitor or run the following command:
- Example command output:
#
/usr/openv/netbackup/bin/admincmd/bpdbjobs -report
JobID Type State Status Policy Schedule Client Dest Media Svr Active PID FATPipe Job Method
58 Image Delete Done 1 12767
57 Image Delete Done 1 16827
56 Image Delete Done 1 21063
55 Image Delete Done 1 24940 Note: The last jobid is 58.
- Example command output:
Stop all the NetBackup services and close the NetBackup Java/Admin console.
Remove the empty jobid file and related lock file.
Example commands and output:
# ls -l /usr/openv/netbackup/db/jobs | grep jobid
-rw------- 1 root root 0 Jan 12 01:28 jobid
-rw------- 1 root root 16 Jan 12 01:28 jobid.lock
# cd /usr/openv/netbackup/db/jobs
# rm jobid jobid.lock
Rebuild the jobid file.
Example commands:
# cd /usr/openv/netbackup/db/jobs
# echo > jobid 58
Start the NetBackup services.
Note: After completing the steps above, NetBackup services should start properly, and jobs should show in the Activity Monitor.