Unable to view active jobs in the activity monitor

Article: 100007969
Last Published: 2012-07-28
Ratings: 0 2
Product(s): NetBackup & Alta Data Protection

Problem

No status of the jobs in the activity monitor, happening for both User and schedule backup.

 

Error Message

N/A: The Activity Monitor is blank in the Administration Console.

 

Cause

The jobid file is empty.

Unix/Linux: /usr/openv/netbackup/db/jobs/jobid
Windows: install_path\Veritas\NetBackup\db\jobs\jobid

 

Solution

Need to rebuild the jobid file.

  1. Check the last jobid from the activity monitor or run the following command:
    • Example command output:
      #
      /usr/openv/netbackup/bin/admincmd/bpdbjobs -report
      JobID         Type State Status Policy Schedule Client Dest Media Svr Active PID FATPipe Job Method
         58 Image Delete  Done      1                                            12767
         57 Image Delete  Done      1                                            16827
         56 Image Delete  Done      1                                            21063
         55 Image Delete  Done      1                                            24940
    • Note: The last jobid is 58.

  2. Stop all the NetBackup services and close the NetBackup Java/Admin console.

  3. Remove the empty jobid file and related lock file.

    • Example commands and output:
      # ls -l /usr/openv/netbackup/db/jobs | grep jobid
          -rw-------   1 root     root           0 Jan 12 01:28 jobid
          -rw-------   1 root     root          16 Jan 12 01:28 jobid.lock
      # cd /usr/openv/netbackup/db/jobs
      # rm jobid jobid.lock

  4. Rebuild the jobid file.

    • Example commands:
      # cd /usr/openv/netbackup/db/jobs
      # echo > jobid 58

  5. Start the NetBackup services.

Note: After completing the steps above, NetBackup services should start properly, and jobs should show in the Activity Monitor.

 

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