Highly Available Hyper-v Virtual machine is not listed under the Highly Available machines in the Failover Cluster Manager post restore
Problem
Highly Available (HA) Virtual Machine (VM) is not listed as HA VM under 'Service and applications' in Failover Cluster Manager post restore from Backup Exec
Cause
This happens if Virtual Machine is deleted from the Failover Cluster manager and then a restore is performed.
Solution
This behavior is by design. If the Virtual Machine is deleted from Failover Cluster Manager, then the restore is like a redirected restore and so the VM is not registered as a HA VM in cluster manager.
The restored VM will be registered in the Hyper-V manager on the node which owns the Quorum. To add the VM as HA VM in Failover Cluster Manager, follow the steps below.
1- Connect to the Hyper-V cluster using Failover Cluster Manager
2- Right-click on the ‘Services and applications’ header in the left pane of the Cluster Manager and select ‘Configure a Service or Application…’
3- In the High Availability Wizard, click next on the first page, then select ‘Virtual Machine’ from the list of available service and application types.
4- Select the virtual machines you wish to make highly available and follow the wizard to completion.