After upgrading NetBackup Appliance to 2.7.2 Java fails with: Could not connect to Netbackup Service Layer

Article: 100032061
Last Published: 2018-01-23
Ratings: 0 0
Product(s): Appliances

Problem

After upgrading NetBackup Appliance to 2.7.2, attempts to launch the Java GUI may fail with the pop-up error:  Could Not Connect to NetBackup Service Layer.  It then redirects to Backup Archive Restore interface.



     
   

Error Message

On the master server the following may be seen in the bpjava-msvc log (Verbosity at 5):

[25-02-2016 09:54:32:679] vxssiop.connection:INFO: createSocket - Trying to connect to <MasterHostname> :1556:nbsl_secsvc
(ObjSvc)org.jacorb.orb.Reference._non_existent,,63064
    Request ID: 0
    Server: <MasterHostName>
    Time Taken: 63064ms
    Successful:
    Reply Status: Unknown
    SystemException: org.omg.CORBA.TIMEOUT

[2/25/16 9:54:33 AM EST {1456412073695}] [262144] ICACHE.ObjectService.CORBAImpl-> Timed out connecting to nbsl.



Path to the bpjava-msvc log file:
UNIX/Linux:  /usr/openv/netbackup/logs
Windows:   <install_path>\Veritas\NetBackup\logs

Cause

On the workstation that is launching Java, the   <installpath>\veritas\java nbjconf file has the following entry set to 60 seconds: NBJAVA_CORBA_DEFAULT_TIMEOUT = 60
A message similar to the following can be found in the log showing the time taken to process just before failure: Time Taken: 63064ms Successful: Reply Status: Unknown SystemException: org.omg.CORBA.TIMEOUT [2/25/16 9:54:33 AM EST {1456412073695}] [262144] ICACHE.ObjectService.CORBAImpl-> Timed out connecting to nbsl.

Solution

To work around this issue, edit <installpath>\veritas\java\nbjconf to change  NBJAVA_CORBA_DEFAULT_TIMEOUT  from 60 to 120.     

 

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