Monitoring Status section of the Vault Administration Console (VAC) shows old and incorrect warning

Article: 100024733
Last Published: 2015-05-13
Ratings: 1 0
Product(s): Enterprise Vault

Problem

Errors or Warnings show up on the Status screen of the Administration console.

Such warnings are not valid due to age (Last run time is older than the others) or checks a value that is not available (Fingerprint databases on Vault Stores that do not have one)

Rerunning all the checks and restarting the services do not fix the issue.

Error Message

Space in Vault Store fingerprint database log

The monitor terminated unexpectedly.
Details:
System.Runtime.InteropServices.COMException (0x80040E14):
Exception from HRESULT: 0x80040E14 at
KVS.EnterpriseVault.Interop.StorageManageClass.GetFPCDBTransactionLogSizes(String
siteEntryId, String& pBackupSettingsXML) at
KVS.EnterpriseVault.Monitoring.VSG_DB_TL_Size.RunNow(MonitorRunType runType) at
KVS.EnterpriseVault.Monitoring.MonitoringThreadBase.ScheduleThread()

Cause

Historically this was a monitored and valid resource used by Enterprise Vault. but system changes have removed the need for the applicable check but retained the orphaned information related to the resource in the database, producing a warning.

Solution

Search the MonitoringHistory table on the EnterpriseVaultDirectory database and look for the entry detailing the error. Using the information from the status message, the following query can narrow down the erroneous entry by modifying the Year, Month, and Day to reflect the values found in the warning. It is important to note that the date in the database is UTC while the date in the VAC status window is converted to local computer time. It might be necessary to adjust the time from the VAC to UTC for this query.

USE EnterpriseVaultDirectory
SELECT MonitoringHistoryIdentity, Source, StartDateUTC
FROM MonitoringHistory
WHERE YEAR(StartDateUTC) = 2011
AND MONTH(StartDateUTC) = 01
AND DAY(StartDateUTC) = 28

Using the source and date, identify the problematic entry and note the MonitoringHistoryIdentity associated with that item. Backup the EnterpriseVaultDirectory DB prior to making any modifications. Once backup is complete, use this MonitoringHistoryIdentity recorded above in the following query:

 

DELETE FROM  MonitoringHistory WHERE MonitoringHistoryIdentity = ID_NUMBER
 
 
Replace ID_NUMBER with the MonitoringHistoryIdentity recorded earlier and expected to be causing the issue.
 
 
Once the entry has been deleted restart the Administration Console and re-run all checks.
 
 
Confirm applicable message no longer recurs.
 

 

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