Problem
Some calendar items in Outlook are not getting archived.
Cause
This issue may be caused by the fact that calendar items with additionally invited people have a different message class than standard calendar events. Calendar events with more than one attendee are considered meetings.
- Normal calendar events have a message class of IPM.Appointment*
- Meetings have a message class of IPM.Schedule*
By default, Enterprise Vault does not include the message class IPM.Schedule*.
Solution
In order to resolve this issue, add the IPM.Schedule* message class to Enterprise Vault and enable it in the Exchange archiving policy.
Add the IPM.Schedule* message class to Enterprise Vault:
- In the Enterprise Vault Administration Console, right-click on Directory on [EV_Server_Name] and select Properties.
- Click on the Exchange Message Classes tab.
- Click on the Add... button.
- In the Class field, enter the message class IPM.Schedule*.
- In the Description field, enter a description like Meeting Requests.
- Click OK to save the message class to the list.
- Click OK again to close the Directory Properties dialog box.
Enable IPM.Schedule* for archiving in the Exchange Mailbox Policy:
- In the Enterprise Vault Administration Console, right-click on the specific Exchange Mailbox Policy to enable IPM.Schedule* and select Properties.
- Click on the Message Classes tab.
- Check the box next to IPM.Schedule*.
- Click OK to save the changes to the Policy.
- Synchronize the mailboxes affected by the policy update.
Note: In order to synchronize mailboxes, go to Tasks under the appropriate Enterprise Vault Server in the console, right-click on the Exchange Mailbox Archiving Task for the server the affected users are on and select Properties. On the Synchronization tab, click the Synchronize button.