Veritas System Recovery Disk creation fails with Error ECA3138D and ECA31F48.

記事: 100049289
最終公開日: 2021-01-06
評価: 3 1
製品: System Recovery

Problem

Veritas System Recovery Disk (SRD) creation fails with Error ECA3138D and ECA31F48 while "Adding drivers to recovery disk" process is running.

Error Message
 

Veritas System Recovery Disk not created.

ECA3138D Failed to compile a list of INF files in INF directory.
ECA31F48 Failed to get all drivers from WinPE mounted path.

Figure 1

Figure 2

Cause

The issue happens when the path length is too long when SRD wizard attempts to embed auto-detected drivers into the SRD.

Solution

 

Workaround:
Temporarily change a path (%USERPROFILE%\AppData\Local\Temp) for user environment variable “Tmp” to C:\sr with the below steps.

1. Open File Explorer.

2. Right-click “This PC”.

3. Click “Advanced System Settings”.

4. Click “Environment Variables”.

5. Click “TMP” in User variable for Administrator.

6. Press “Edit”.

Where, C:\sr does not need to be created by yourself since the SRD wizard creates it.

7. After rebooting the system, create the SRD again.

8. After the completion of the creation, revert the user environment variable “TMP” to  “%USERPROFILE%\AppData\Local\Temp”. 

9. Reboot the system.


 

Veritas has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Veritas is committed to product quality and satisfied customers.
 
This issue is currently under investigation by Veritas. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see  http://www.veritas.com Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

 

NOTE:
Customers experiencing this issue are encouraged to contact Veritas Technical Support as data is still being collected to assist in resolving this issue.

参照

Etrack : 4022996

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