Problem
After adding new TEMP license keys, media servers may show they are offline.
- The same may happen if a media server was shut down, before performing system/SAN changes or maintenance on the media server.
- Media server is not active for tape devices.
Error Message
Media server showing offline
Media server not showing "Active for Tape and Disk"
Cause
Multiple potential causes.
Solution
Run the nbemmcmd command to update the host's machine state, which is located in the following path:
Unix: /usr/openv/netbackup/bin/admincmd/
Windows: install_path\NetBackup\bin\admincmd\
If the media server is not active for tape:
nbemmcmd -updatehost -machinename <media_server_hostname> -machinetype media -machinestateop set_tape_active -masterserver <master_server_hostname>
If the media server is not active for disk:
nbemmcmd -updatehost -machinename <media_server_hostname> -machinetype media -machinestateop set_disk_active -masterserver <master_server_hostname>
Note: Sometimes the above may not work because connection is still not established with the PBX service.
To establish the PBX connection between the master and media server run the command:
nbemmcmd -updatehost -machinename <media_server_hostname> -machinetype media -machinestateop set_master_server_connectivity -masterserver <master_server_hostname>
Then, refresh the NetBackup Administration Console and the media server status should be back to it's previous state.