Sign In
Forgot Password

Don’t have an account? Create One.

Silent data corruption on NetBackup Appliances (article 100042674)

HotFix Critical

Abstract

Resolves silent data corruption on NetBackup Appliances

Description

Problem

A VxFS issue may cause silent data corruption on NetBackup appliances with the following software versions:

  • 2.7.3
  • 3.0

This article contains the following EEBs:

  • SYMC_NBAPP_EEB_ET3941402-2.7.3.0-1
  • NBAPP_EEB_ET3936093-3.0.0.0-1


These EEBs fix the following issue:

Using the writev() call with a VxFS filesystem results in null data being written to the file, which can cause silent data corruption.


Error Message

No error messages appear when silent data corruption occurs.

Read me

Problem

A VxFS issue may cause silent data corruption on NetBackup appliances with the following software versions:

  • 2.7.3
  • 3.0

This article contains the following EEBs:

  • SYMC_NBAPP_EEB_ET3941402-2.7.3.0-1
  • NBAPP_EEB_ET3936093-3.0.0.0-1


These EEBs fix the following issue:

Using the writev() call with a VxFS filesystem results in null data being written to the file, which can cause silent data corruption.


Error Message

No error messages appear when silent data corruption occurs.


Cause

This is a known VxFS issue. For more information, refer to the following article: https://www.veritas.com/support/en_US/article.000122719


Solution

The attached EEBs resolve this issue for all of the above listed software versions. To resolve this issue, the Veritas Storage Foundation team has published a hotfix that is included in these EEBs. The hotfix is applied when you complete the EEB installation.


Note: This issue is fixed in appliance software versions 3.1 and later.

You must reboot the appliance after the EEB installation has completed (see step 8).

Install the EEB as follows:

  1. Log in to the NetBackup Appliance Shell Menu.
  2. Go to the Manage > Software view and run the following command:
  3. Share Open
  4. On the host where you downloaded the EEB, mount the following share location: /inst/patch/incoming
  5. Copy the EEB to the mounted share location.
  6. Return to the appliance shell menu, go to the Manage > Software view, then run the following command: Share Close
  7. Run the following command to verify that the EEB was downloaded to the appliance:
  8. Manage > Software > List Downloaded
  9. Run the following command to install the downloaded EEB file (the version 3.0 EEB file name is used as an example):
  10. Install NBAPP_EEB_ET3936093-3.0.0.0-1.x86_64.rpm                                                    
  11. Reboot the appliance after the EEB installation has completed.


Update files

File name Description Version Platform Size

Applies to the following product releases