Flex web console Activity Monitor task "Recovering application instance" hangs at 25% when stopping or starting a NetBackup instance.
Problem
Flex web console Activity Monitor task "Recovering application instance" hangs at 25% when stopping or starting a NetBackup instance.
Error Message
None, but a hang occurs at 25%.
Cause
If a Flex instance's NetBackup services are stopped or started using netbackup stop/start or bp.kill_all/bp.start_all, the services are disconnected from systemd control.
- When this occurs, the Flex appliance console can no longer manage the NetBackup services.
- This condition can be confirmed from a SSH prompt on the NetBackup appliance via command: systemctl status netbackup
- If that command reports dead, the condition described exists.
Solution
Do not use these commands to manage NetBackup services on a Flex instance:
- netbackup start
- netbackup stop
- bp.start_all
- bp.kill_all
Instead, always use the following commands:
- systemctl status netbackup
- systemctl start netbackup
- systemctl stop netbackup
To resolve the hanging recovering application instance task:
1. Confirm the status of the NetBackup services from a SSH prompt while logged in as appadmin on the affected NetBackup instance by running the commands below:
systemctl status netbackup
a) if services are running but the Active: status reports dead, then run:
systemctl start netbackup
b) if services are stopped but the Active: status reports dead, then run:
systemctl stop netbackup
c) After either action above, confirm the dead status is no longer reported by running:
systemctl status netbackup
2. At this point the hanging "Recovering application instance" status will change to failed and the appropriate commands can be used.