Problem
NetBackup IT Analytics upgrade failed. This can affect both Windows and Linux platforms.
Error Message
From upgrade.log
<ITA_home>\aptare\upgrade\logs\upgrade.log
[com.aptare.sc.service.objectHierarchy.ConcreteObjectHierarchyService]: Constructor threw exception; nested exception is java.lang.IllegalArgumentException: Invalid list of licenses FOUNDATION,STORAGE
Cause
Issues with the license during the upgrade.
Solution
1) Generate the proper license key from the Customer VEMS portal. Reach out to the account team for questions about licensing.
2) Stop tomcat-portal:
Linux:
/opt/aptare/bin/tomcat-portal stop
Windows:
Stop Aptare services from Windows Services snap-in.
3) Clean up all the old licenses that have been applied:
Linux:
/opt/aptare/utils/removeLicenseFiles.sh
Windows:
<InstallPath>\aptare\utils>removeLicenseFiles.bat
Note: License files are stored in the directory: <APTARE_HOME>/portalconf/licenses/
4) Install only the new temp license:
Linux:
/opt/aptare/utils/installlicenseUI.sh
Windows:
<InstallPath>\aptare\utils>installlicense.bat
5) Start tomcat-portal:
Linux:
/opt/aptare/bin/tomcat-portal start
Windows:
Start Aptare services from Windows Services snap-in