Problem
Nbpem may crash with assertion failure after changing Schedule type from Calendar to Frequency, which will set default value of Frequency to fixed number listed below:NetBackup 7.7.x: Frequency value will be set to 596523 hours.
NetBackup 8.0: Frequency value will be set to 1 second.
Screenshots & Contents of <NetBackup Installation directory>\veritas\netbackup\db\class\ <policy name>\schedule\ <schedule name>\info on Windows:
- NetBackup 7.7.x
RETENTION_LEVEL 1 1 1 1 1 1 1 1 1 1
INCREMENTAL_TYPE 0
FREQUENCY 2147482800 <===== Frequency in seconds
CALENDAR 0
MAX_FRAG_SIZE 0
MAX_MPX 1
NUMBER_OF_COPIES 0
FAIL_ON_ERROR 0
SYNTHETIC 0
CHECKSUM_VALIDATION 0
PFI_RECOVERY 0
RESIDENCE *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL*
POOL *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL*
SHARE_GROUP *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL*
RES_IS_SS 0
SCHED_INDEXING 0
- NetBackup 8.0
RETENTION_LEVEL 1 1 1 1 1 1 1 1 1 1
INCREMENTAL_TYPE 0
FREQUENCY 1
CALENDAR 0
MAX_FRAG_SIZE 0
MAX_MPX 1
NUMBER_OF_COPIES 0
FAIL_ON_ERROR 0
SYNTHETIC 0
CHECKSUM_VALIDATION 0
PFI_RECOVERY 0
RESIDENCE *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL*
POOL *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL*
SHARE_GROUP *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL* *NULL*
RES_IS_SS 0
SCHED_INDEXING 0
Error Message
Nbpem crashes with assertion failure.
Cause
From NetBackup Administration Console, if just changing schedule type from Calendar to Frequency, default value of Frequency will be set to 596523 hours for NetBackup 7.7.x, to 1 second for NetBackup 8.0.
With a similar large value set to Frequency, nbpem may crash with assertion failure.
Please note: NetBackup Administration Console GUI will convert any Frequency value larger than 596523 hours to 596523 hours.
Solution
This issue is resolved in 8.1 and later versions of NetBackup.
Workaround:
When changing schedule type of a policy from Calendar to Frequency, please make sure to check the setting of Frequency and set it to an appropriate value.
Veritas Technologies LLC has acknowledged that the above-mentioned issue (Etrack 3905860) is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers.
This issue is currently being considered by Veritas Technologies LLC to be addressed in the next revision of the product. There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. Please note that Veritas Technologies LLC reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas’ plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.
Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue. For information on how to contact Veritas Sales, please see https://www.veritas.com