Backups of open temporary Microsoft Office document files (~*.*) fail

Article: 100032194
Last Published: 2020-12-03
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

When attempting to backup open Temporary Microsoft Office document files, the read operation fails with "(WIN32 32: Unknown error) or (WIN32 32: The process cannot access the file because it is being used by another process. )" even though a (VSS) Volume Shadow Copy Service snapshot was successfully taken at the start of the backup job.

This causes backup jobs to complete with a Exit Status 1.

Temporary Microsoft Office files begin with a tilde sign:  ~

Example File Names:

  • ~filename.xlsx
  • ~filename.docx

Error Message

The NetBackup Activity Monitor Job Details show the following warnings:


DATE TIME - Warning bpbrm (pid=*) from client client_name: WRN - can't open file: PATH/~Filename.** (WIN32 32: Unknown error)
(Where * = PID and ** = Office document extension)

A NetBackup client-side ...\logs\ bpbkar log file captures the following content:


(WIN32 32: The process cannot access the file because it is being used by another process. )
(WIN32 32: Unknown error)

Cause

Despite the fact that a successful VSS Volume Shadow Copy Service snapshot occurred for the volume on which the Microsoft Office Temporary Files reside, the Microsoft Application creates a handle to the temporary file which prevents VSS from performing the necessary Snapshot Copy operation for this data.

 

Solution


It should not be necessary to backup Microsoft Office Temporary Files.  Microsoft Office Temporary Files are temporary in nature.  The life-cycle of these files are the duration the application is running.  

On top of this, the MS Office application performs an "auto-save" operation every 10 minutes. During this operation it merges the contents of the temporary file into the main file.

If you are encountering Status 1 jobs due to the inability to backup Temporary Microsoft Office files, create a client-side exclusion that is policy-agnostic for  ~*.*.

This will exclude all files from all policies matching the pattern ~*.*.

  • Open the Admin Console and go to Host Properties -> Clients -> Client_Name
  • Navigate to Windows Client -> Exclude Lists
  • Click Add and in the Policy drop down list, ensure it says <<All Policies>>, and the same for the Schedule drop down.
  • In the Files/Directories box, put in: ~*.*
  • Press Add and then Close.

Note: This will exclude any file that contains the first character as '~' and then have a '.' in them anywhere after the tilde.

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