Problem
Client behavior: Vault Cache does not synchronize or download any items.
Error Message
When viewing the Vault Cache properties, it will display "No Vaults Available", and the synchronization will not run. Additionally, the header synchronization could show an error: "Failed: Could not connect to Server"
Cause
2. In the log, a call to /EnterpriseVault/ListArchives.aspx, will be seen:
Later in the log, the following the can be seen:
HDR:SYNC: ListArchives:<ListArchivesResponse><Archives Date="1244763232"/></ListArchivesResponse>
There is no Archive information because impersonation is disabled, and the user, NT AUTHORITY\SYSTEM, does not have permission to the archive information.
A Dtrace of the AuthServer process will show:-
(AuthServer) <11172> EV:M CClientAuthIntImpl::RegisterClientIdentity Registering currently impersonated client. User:NT AUTHORITY\SYSTEM Flags:None (0x0) (hr=Success [0])
3. Browsing to the following URL will produce the below result: http://<evserver>/EnterpriseVault/ListArchives.aspx (Replace <evserver> with the name of the EV server)
<?xml version="1.0" encoding="utf-8" ?>
<?xml version="1.0" encoding="utf-8" ?>
-<http://<evserver>/EnterpriseVault/ListArchives.aspx>; <MDCSyncResponse hr="0" msg="SUCCESS">
-<http://<evserver>/EnterpriseVault/ListArchives.aspx>; <ListArchivesResponse>
<Archives Date="1239246395" />
</ListArchivesResponse>
</MDCSyncResponse>
- <MDCSyncResponse hr="0" msg="SUCCESS">
- <ListArchivesResponse>
- <Archives Date="1240007567">
<Archive ArchiveName="Administrator" Structured="1" IndexingLevel="1" VaultEntryId="11C1F8475374A2148A3AB86F5921D33551110000EVSITE" Type="9" WebAppURL="http://<evserver>/EnterpriseVault" />
</Archives>
</ListArchivesResponse>
</MDCSyncResponse>
4. There will be no *.mdc file in the OV Root Path.
Solution
The EnterpriseVault virtual directory in IIS should have "ASP.NET Impersonation" and should be changed to "Enabled"
1. Open IIS Manager
2. Expand Sites
3. Select Enterprise Vault in the left pane and click Authentication
4. Confirm ASP.NET Impersonation is set to disabled and if so change this to enabled.
5. Restart IIS
6. Open the following URL https://<evserver>/EnterpriseVault/ListArchives.aspx on client machine. It should now return the user's archive information. (Replace <evserver> with the name of the EV server)
7. Perform a manual synchronization of Vault Cache from Outlook. It should start synchronizing and downloading items as expected.