Browsing multiple Oracle instances on the same server may fail with an "Access Denied" error.

Article: 100019211
Last Published: 2023-10-25
Ratings: 0 0
Product(s): Backup Exec

Problem

Browsing multiple Oracle instances on the same server may fail with an "Access Denied" error.
 

Error Message

Access Denied 
 

 

Cause

When browsing multiple Oracle instances on the same server, the enumeration of the second instance fails with an "Access Denied" error.

The same issue might be visible when adding the second instance in the Backup Exec Agent Utility.
 

 
Background
 
When Backup Exec enumerates the first instance during the browsing process, it will use the environmental variables including the path to the tnsnames.ora file for the first instance for all instances.
If the tnsnames.ora file does not show any information of the additional instance(s), then Backup Exec will not be able to connect to it.
 

 
Please be aware:
 
The Backup Exec Agent for Oracle on Windows or Linux Servers does not support multiple Oracle databases of different versions that are installed on the same computer.

The below mentioned solutions are applicable only to servers running multiple Oracle instances of the same version.

 

Solution


A. Restart the Backup Exec Remote Agent and check if the second instance can now be added without any error.

B. Configuring the tnsnames.ora of each instance to include information about the other instance which will allow Backup Exec using either tnsnames.ora file to enumerate all instances on this server.
 
Example of the tnsnames.ora file for the first instance:
 
# Generated by Oracle configuration tools.
 
instance1 =
 (DESCRIPTION =
   (ADDRESS = (PROTOCOL = TCP)(HOST = 10.10.2.2)(PORT = 1111))
   (CONNECT_DATA =
     (SERVICE_NAME = instance1)
   )
 )
 
instance2 =
 (DESCRIPTION =
   (ADDRESS = (PROTOCOL = TCP)(HOST = 10.10.2.3)(PORT = 1112))
   (CONNECT_DATA =
     (SERVICE_NAME = instance2)
   )
 )



 

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