検索クエリーを入力してください
すべてのサポートコンテンツとコミュニティコンテンツを検索...
記事: 100036826
最終公開日: 2017-07-13
評価: 0 3
製品: System Recovery
問題
システム予約済みパーティションを含むシステムに対して SSR 2013 を使ってバックアップジョブを実行すると失敗して、次のメッセージが表示される
エラーメッセージ
エラー E4F3000E: ボリュームシャドウコピーサービスの使用中にスナップショットエラーが発生しました。アプリケーションイベントログで VSS エラーを確認してください。エラーコード: EndCreateSnapshotSet(-2147212529)
(UMI:V-281-1267-14)
原因
他社製の VSS プロバイダ (StorageCraft Shadow Copy Provider) との競合が考えられます。
解決方法
システム予約済みパーティションをバックアップする場合や、バックアップジョブにこれが含まれている場合に、この問題が発生しています。
他のドライブのバックアップはエラーがなく正常に動作するようです。StorageCraft Shadow Copy Provider サービスを無効にすることで競合が解決して、SSR によるバックアップが成功しています。そのためには、以下の手順に従います。
- CMD ウィンドウを開き、次のコマンドを実行します。vssadmin list providers
- これにより、システムにインストール済みの Microsoft VSS プロバイダおよびその他の VSS プロバイダが表示されます。
- 表示された中に StorageCraft Volume Snapshot Software Provider があるかを確認します。存在する場合、サービスコンソールを開いて、StorageCraft Shadow Copy Provider という名前のサービスを無効にします。そのためには、[スタートアップの種類]を[手動]から[無効]に変更します。
- バックアップジョブを実行すると、エラーが発生しないはずです。
注意: StorageCraft Shadow Copy Provider サービスを無効にすると、StorageCraft アプリケーションが動作しなくなる可能性があります。結果を理解したうえで無効にすることをお勧めします。StorageCraft Shadow Copy Provider サービスを使う必要がある場合、SSR バックアップの完了後に有効にすることができます。有効にした場合、スケジュール済みの SSR バックアップジョブの実行前に無効にする必要があります。