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Executive Summary

Infoscale supports containerization using the platforms like Kubernetes and OpenShift. The use of
Infoscale in Kubernetes helps customers to easily manage their containers, automate deployment
processes, and scale their applications as needed, thus providing the reliability and scalability that
businesses need to succeed in today's fast-paced digital landscape. Apart from Disaster Recovery,
Infoscale also provide functionalities like Fencing, Licensing, Snapshots, Clones, VVR, CSI, DR for Cloud,
etc. Some of the disaster recovery features in Infoscale for Kubernetes include:

e Data Backup and Recovery: Infoscale provides automated backup and recovery options to help
customers protect their data and applications.

e High Availability: Infoscale provides high availability features such as automatic failover and self-
healing capabilities, to help ensure that applications continue to run even in the event of
hardware failures or other disruptions.

In Infoscale DR, data can be securely sent in encrypted format by using keys acquired from KMS server.
This paper is focussed on KMS server-side configuration and Infoscale DR client-side configuration.

Infoscale for Kubernetes

Infoscale provides high-performance shared storage for the OpenShift or Kubernetes clusters by using the
fast storage, which is directly attached to the cluster nodes. Infoscale Storage provides highly available
persistent storage that conforms to CSl specifications for enterprise applications by using high-
performance parallel storage access on shared storage (SAN)or in Flexible Storage Sharing
(FSS)environments.

DR in Infoscale for Kubernetes

Disaster recovery refers to the process of restoring an organization’s systems and data in the event of a
natural or man-made disaster. This includes restoring hardware, software, and data from backups, as well
as implementing measures to prevent data loss and minimize downtime. One key component of disaster
recovery is data backup and recovery. Another important aspect of disaster recovery is ensuring that
systems can be quickly and easily restored in the event of a disaster. Infoscale in Kubernetes environment
achieves this with the help of a DR Manager, which orchestrates migration and takeover flow and
provideuseful messages/errors related to the communication between the two sites. The DR in Infoscale
works as below:
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Fig 1: DR Configuration Between two clusters.

Data Encryption in Infoscale DR for Kubernetes

In infoscale DR, encryption is not enabled by default. But when encryption is enabled, user data is
encrypted by using symmetric key encryption and sent in an encrypted format. These keys are acquired
from the KMS server.

About the Custom CA Configuration on Kubernetes Cluster

Certificate Authority (CA) is a trusted entity that issues the SSL certificates. Infoscale cluster can be
configured by using a self signed issuer or custom CA. When data encryption is enabled, Infoscale cluster
need to be configured with custom CA.

In this document Kubernetes certificate and key is used as root authority for custom CA configuration.
Any other tool can be used to configure the custom CA.

Pre-requisites:

1. Download tools cfssl and cfssljson. Run the following commands.
go get / install github.com/cloudflare/cfssl/cmd/cfssl
go get / install github.com/cloudflare/cfssl/cmd/cfssljson

2. Use certificate and key from following path on Kubernetes cluster.
/etc/kubernetes/pki/ca.crt
/etc/kubernetes/pki/ca.key

3. Create vxconfig.json file with the following contents.

"signing™: {
"default": {
"expiry": "43800h"
by
"profiles": {
"cluster": {
"expiry": "8760h",
"usages": [
"signing",
"key encipherment",

"cert sign",
"server auth",
"client auth”

1.
"ca constraint": {
"is ca": true

4. Create csr_config.json file with the following contents



"CN": "infoscale-ca",
"key": {
llalgoll llrsall,
"size": 2048

bo
"hosts": |
"kubernetes"
1.
"names": [
{
"O": "system:nodes",
HOU": ” n

Step 1: Generate Infoscale-ca CSR and Key as under

[root@r7515-046-vm4 sec]#

[root@r7515-046-vm4 secl# cfssl genkey csr config.json | cfssljson -bare infoscale-ca
2023/02/26 13:32:04 [INFO] generate received request

2023/02/26 13:32:04 [INFO] received CSR

2023/02/26 13:32:04 [INFO] generating key: rsa-2048

2023/02/26 13:32:04 [INFO] encoded CSR

[root@r7515-046-vm4 secl# ls

csr confi son 1infoscale-ca.csr infoscale-ca-key.pem vxconfig.json
[Toot@r7515-046-vm4 secl# [J

Step 2: Generate Infoscale-ca Certificate as under

onfig.json




Step 4: Apply custom-ca.yaml created in above step on all member clusters which are a part of DR and
verify Infoscale-ca secret is created

[root@r7515-046-vm4 sec]# kubectl -n infoscale-vtas get secret
NAME TYPE DATA AGE

infoscale-ca kubernetes.io/tls 3 6dl7h

Infoscale Configuration on Kubernetes
Configure Infoscale cluster on all Kubernetes clusters which are a part of DR.

Infoscale cluster can be configured by applying yamls like sro, sr, lico, license_cr, iso, cr in the same
sequence. For more details, see:
https://sort.veritas.com/documents/doc details/IEK/8.0.200/General/Documentation/

[root@r7515-046-vm4 ~]# kubectl -n infoscale-vtas get pods

NAME READY STATUS RESTARTS
infoscale-csi-controller-32414-0 5/5 Running 50 (42h
infoscale-csi-node-32414-5rpf5 2/2 Running 22
infoscale-csi-node-32414-bckkc 2/2 Running 22
infoscale-csi-node-32414-ghj9q 2/2 Running 22
infoscale-dr-manager-57d9£9588-hx5735 1/1 Running
infoscale-fencing-controller-32414-5d8455587-clgwr 1/1 Running
infoscale-fencing-enabler-32414-4f7qg4 1/1 Running
infoscale-fencing-enabler-32414-ktvhn 1/1 Running
infoscale-fencing-enabler-32414-shézg 1/1 Running
infoscale-licensing-operator-d4f6£f5bb3-kdégb 1/1 Running
infoscale-sds-32414-5cad07¢c8bf71158c-97gzx 1/1 Running
infoscale-sds-32414-5cad07c8bf71158c-jpbng 1/1 Running
infoscale-sds-32414-5cad07c8bf71158c-pcijbc 1/1 Running
infoscale-sds-operator-54496584db-h4751 1/1 Running

About the KMIP Secret Configuration

KMIP Secret contains the KMS server and port information. Using this secret the cluster can be connected
with the KMS server.

Pre-requisites:

1. KMS server must be pre-configured and KMS server hostname or IP address and port details must
be ready

2. The KMS server hostname must be Base64 encoded.

3. the KMS server port must be Base64 encoded.
infoscale-kmip-encrypt.yaml must be created by using encoded hostname and port.


https://sort.veritas.com/documents/doc_details/IEK/8.0.200/General/Documentation/

[root@r7515-046-vmd secl#
[root@r7515-046-vm4 sec]# cat infoscale-kmip-encrypt.yaml
apiVersion: vl

data:
host: MTAUMjEwLjE4Mi4xOTgK
port: NTYS5Ngo=

kind: Secret

metadata:
name: infoscale-kmip-encrypt

namespace: infoscale-vtas

type: Opaque

Step 1: Apply infoscale-kmip-encrypt.yaml created in above step on all member clusters which are a part
of DR and verify infoscale-kmip-encrypt is created.

[root@r7515-046-vmd secl#
[root@r7515-046-vm4 sec]# kubectl -n infoscale-vtas get secret | grep kmip
infoscale-kmip-encrypt Opaque 2 6d17h

[root@r7515-046-vmd secl# |

About the KMS Server Certificate Configuration

Create server certificate on KMS server. Client clusters can connect to the server by using this server
certificate.

Pre-requisites:
1. KMS web server must be accessible with the given credentials and port details.

Step 1: Login to IBM security key lifecycle manager (https://<kms-server>:<port>/ibm/SKLM/login.jsp)

Step 2: Go to Advance Configuration -> Server Certificate



IBM Sacurity Guardium Key Lifacycle Manager skimadmin
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Step 3: Go to Add -> Request Certificate from a third party

IBM Security Guardium Key Lifecycle Manager sklmadmin ~

Advanced Gonfiguration

Add TLS/KMIP Certificate

Administer Server Certificates

slgned certificate
ned cerlificate in & known environment. A diienl cannol verily a self-signed cerliicale befare accepling a connection

® Request certificate from a third-party provider
a third-party provider as a mora secura means of communication. A client can verify a certificate from a third-party provider

Generate Certificate Request for Third-party Provider

*Certificate label in keystore:

*Certificate description (common name]

“velidity period of new certificate {in days; for example, 3 years is 365 x 3 = 1095 days):

1085 : The interval in days ranges from 1 to 9000
*Algorithm:
RSA -
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Add Certificate Cancel
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Certificate Scertificate-label.csr is generated at /opt/IBM/WebSphere/AppServer/products/skim/ on the

KMS server
Step 4: Copy Scertificate-label.csr from the KMS server to the local kubernetes cluster.

Step 5: Sign the CSR on the kubernetes cluster to generate the server certificate.

Step 6: Web login KMS Server -> Welcome -> Third party certificates pending import.

IBM Security Guardium Key Lifecycle Manager skimadmin
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Step 7: Click on Server Certificate and import server-cert.pem



Step 8: Go to Advance Configuration -> Server Certificate -> Click on server-cert -> Modify -> Enable check
box for the current certificate.

About the Client Certificates Configuration

Client certificate configuration includes get client certificate from the infoscale cluster, register
certificate on KMS server and then create a client group. With this configuration, multiple clusters can
use the same certificates while configuring encrypted volumes.

Pre-requisites:

1. Infoscale cluster must be configured to generate the client certificate.
2. KMS web server must be accessible with the given credentials and port details

Step 1: Get client certificate from all member clusters which are a part of DR

Client certificate from client-one

[root@r7515-046-vmd ~]4
[root@r7515-046-vm4 ~]# kubectl -n infoscale-vtas get secret infoscale-sds-rest-tls-cert-32414
-0 jsonpath="{.data['tls\.crt']}" | basetd --decode > kmip-client-one-cert.crt

[root@r7515-046-vm4 ~]# ls kmip-client-cne-cert.crt
kmip-client-one-cert.crt
[root@r7515-046-vmd ~14 |

Client certificate from client-two

[root@r7515-046-vm9 secl#
[root@r7515-046-vm9 sec]# kubectl -n infoscale-vtas get secret infoscale-sds-rest-tls-cert-32415
-0 jsonpath="{.data['tls\.crt']}" | base64 --decode > kmip-client-twi-cert.crt

[root@r7515-046-vm9 sec]# ls kmip-client-twi-cert.crt
kmip-client-twi-cert.crt
[root@r7515-046-vm9 secl#

Step 2: Register clients on KMS server using client certificates

Login to KMS server web console -> Clients -> Create -> Add client certificate details -> Register Client
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Step 3: Create Client group on KMS server for all registered clients

Login to KMS server web console -> Clients->Client Groups->Add->Client Group Name (Specify client
group name)->Assign Clients (Specify clients which you want to be a part of group)

IBM Security Guardium Key Lifecycle Manager

Welcome Configuration Advanced Configuration - Administration ~ Clients Search User Management

Create Client Group

Client Group N
1M SreUp RAME Client Group Name: DR_GROUP

Assign Clients Clients: None

Search for names.. Search for names..
009-CLIENT - a
009-170CT
>>
| << ‘
Save

Exit

Step 4: Must be able to create PVC on all client clusters by using same certificate from KMS server with
encrypted storage class

Perform following test to validate if DR can be configured for encrypted PVC.



- Apply encrypted storage class on all the clusters

fapiVersion: storage.k8s.io/vl
| kind: StorageClass
| metadata:
name: csi-infoscale-sc-encrypted
annotations:
I storageclass.kubernetes.io/is-default-class:
| provisioner: org.veritas.infoscale

| reclaimPolicy: Delete
allowVolumeExpansion: true
| parameters:
fstype: vxfs
layout: "mirror"
faultTolerance:: "2"
mediaType: "hdd"
encryption: "true"

- Apply PVC with encrypted storage class on all the clusters

kind: PersistentVolumeClaim
apiVersion: vl
metadata:
name: mysgl-pvc-appl-enc
namespace: mysgl
labels:
env: appl
spec:
storageClassName: csi-infoscale-sc-encrypted
accessModes:
- ReadWriteMany
resources:
requests:
storage: 1Gi

- Must be able to configure PVC on all client clusters by using certificate from the same KMS
server.

-n nysgl get pvc
ME

AEGART_29TT-40
€5932¢h7-2277-4°

CAPACITY  ACCESS MODES
161 R csi-i encrypted
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Configure Application on Encrypted Storage Class

Configure PostresSQL application on one of the Kubernetes clusters by using storage from encrypted
storage class. The cluster site where application is configured act as a primary site whereas other clusters
where application is not running act as secondary sites.

Step 1: Apply encrypted storage class on all clusters which are a part of DR.

fapiVersion: storage.k8s.io/vl
| kind: StorageClass
| metadata:
name: csi-infoscale-sc-encrypted
annotations:
I storageclass.kubernetes.io/is-default-class: "false"
| provisioner: org.veritas.infoscale

| reclaimPolicy: Delete
allowVolumeExpansion: true
| parameters:
fstype: vxfs
layout: "mirror"
faultTolerance:: "2"
mediaType: "hdd"
encryption: "true"

Step 2: Apply PVC with encrthed storage class on the primary site.

kind: PersistentVolumeClaim
apiVersion: vl
metadata:
name: postgres-pvc-appl-enc
namespace: postgressqgl
labels:
env: appl
spec:
storageClassName: csi-infoscale-sc-encrypted
accessModes:
- ReadWriteMany
resources:
reguests:

[root@r7515-046-vnd sec]# kubectl -n postgressol get pvc
NAME ST | E CARPACITY  ACCESS MODES S
e pl-e ' 03ed6Te-9ba3-4b9d-a790-217bbladal’d 161 RIX csi-infoscale-sc-encrypte

Step 3: Apply PostgresSQL application on the primary site.
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[root@r7515-046-vm4 secl#
[root@r7515-046-vmd4 sec]# kubectl -n postgressgl get pods
NAME READY STATUS RESTARTS

postgressqgl-appl-£654bbd77-g4qn7 1/1 Running 0
[root@r7515-046-vmd secl#

Configure Application DR

DR can be configured for application by applying following custom resource

- Configure GCM: Cluster membership configured between clusters in DR
- Configure Datareplication: VVR replication configured between clusters in DR
- Configure Disasterrecoveryplans: DR operations can trigger using drplan

For more details, see:
https://sort.veritas.com/documents/doc details/IEK/8.0.200/General/Documentation/

Conclusion

With encryption we can ensure data security at rest and during transmission and disaster recovery
provide high availability for application in the event of cluster failure. This document discusses how DR
can achieved for application configured on persistent storage from encrypted storage class and using IBM
KMS certificates for encryption.
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