Failed to load DR image <DR FILE path> (13) when attempting catalog recovery

Article: 100022710
Last Published: 2011-02-11
Ratings: 0 0
Product(s): NetBackup

Problem

The Catalog backup disaster recovery (DR) file was lost and it was re-created by performing a phase 1 import against the Catalog tape media. When pointing the NetBackup Catalog Recovery Wizard to the re-created DR file and clicking Next, it immediately failed with status code 13.

 

Error Message

NetBackup Catalog Recovery Wizard returns error:

Failed to load DR image C:\DRfile\HotCat_1260423627_INCR (13)

NetBackup admin log shows:

09:15:25.750 [2315.6002] <2> bprecover: INITIATING: NetBackup 6.0 created: 0
09:15:25.750 [2315.6002] <2> logparams: -ldr -path C:\DRfile\HotCat_1260423627_INCR
09:15:25.766 [2315.6002] <2> db_get_image_info: C:\DRfile\HotCat_1260423627_INCR created by phase 1 import in previous release, expire image and re-import
09:15:25.766 [2315.6002] <16> db_loadCatalogDRImage: Bad image header: C:\DRfile\HotCat_1260423627_INCR, error: invalid command parameter (20)
09:15:25.766 [2315.6002] <16> db_loadDRImageFromDisk: Failed to load DR image C:\DRfile\HotCat_1260423627_INCR (13)

Note: The admin log is located in the following location...

  • UNIX/Linux: /usr/openv/netbackup/logs/admin
  • Windows: install_path\Veritas\NetBackup\logs\admin

 

Cause

Phase 1 import alone is not sufficient to re-create a fully usable DR file.

 

Solution

The remedy is to perform phase 2 import against the desired full and incremental catalog backup images.

The bpimport -drfile command can be used to retrieve all Disaster Recovery files from the catalog backup media.

The syntax is as follows:

bpimport -drfile media_id -drfile_dest fully_qualified_directory_name

After bpimport is complete, simply pick the desired Disaster Recovery file and proceed with catalog recovery.

    Note: On Windows 2008 and Windows 2008 R2 platforms, the same symptom may be encountered when bprecover -wizard is run on a command prompt that has no elevated privilege. In this case, re-launch the command prompt window with the Run as administrator option.

    Note: The bpimport and bprecover commands are located in the following location...

    • UNIX/Linux: /usr/openv/netbackup/bin/admincmd
    • Windows: install_path\Veritas\NetBackup\bin\admincmd

    Was this content helpful?