The Enterprise Vault (EV) Outlook Add-in may cause Outlook to hang on startup when Exchange is unavailable

Problem

The Enterprise Vault (EV) Outlook Add-in may cause Outlook to hang on startup when Exchange is unavailable

Error Message

This behavior can be confirmed by looking at the client trace. See the related document for details on how to enable maximum client tracing. If the issue is caused by the MarkPSTs function, something similar to the following will be seen:

30/07/2009 17:54:41.970[3640]: CStore::OpenIPMSubtree: 0x0
30/07/2009 18:01:10.153[3640]: ~CStore::OpenIPMSubtree: 0x8004011D
30/07/2009 18:01:10.154[3640]: ~CDesktop::MarkPSTs: 0x8004011D
30/07/2009 18:01:10.154[3640]: MarkPSTs returned: 0x8004011D

In the above case this function took over 6 minutes to complete. 
 

If the issue is related to Vault Cache, something similar to the following will be seen:

04/08/2009 16:24:24.789[2180]: CDesktop::PopulateTrawlIgnoreFolders: 0x0
04/08/2009 16:24:24.789[2180]: DesktopConfig::GetSetting: 0x0
04/08/2009 16:24:24.790[2180]: DesktopCommonConfig::GetSetting: 0x0
04/08/2009 16:24:24.790[2180]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
04/08/2009 16:24:24.790[2180]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
04/08/2009 16:24:24.790[2180]: Desktop Setting: ArchiveDelItemsFolder
04/08/2009 16:24:24.790[2180]: Value: 0
04/08/2009 16:24:24.791[2180]: ~DesktopCommonConfig::GetSetting: 0x0
04/08/2009 16:24:24.791[2180]: ~DesktopConfig::GetSetting: 0x0
04/08/2009 16:24:24.792[2180]: Adding folder (Deleted Items) to the list of folders the trawler will ignore
04/08/2009 16:25:27.884[2180]: Adding folder (Conflicts) to the list of folders the trawler will ignore
04/08/2009 16:25:27.886[2180]: Adding folder (Sync Issues) to the list of folders the trawler will ignore
04/08/2009 16:25:27.887[2180]: Adding folder (Local Failures) to the list of folders the trawler will ignore
04/08/2009 16:32:17.568[2180]: DesktopCommonConfig::AddSetting: 0x0
04/08/2009 16:32:17.568[2180]: ~DesktopCommonConfig::AddSetting: 0x0
04/08/2009 16:32:17.568[2180]: ~CDesktop::PopulateTrawlIgnoreFolders: 0x8004011D
 

The delay in the above function approaches 8 minutes. 

Cause

This issue can occur if the policy "Mark PSTs" is set to "On" (in the user's Exchange Desktop Policy) or if Vault Cache is enabled. It only happens if the Exchange server is not available (for example, the user is not connected to the internal network and is working offline). 

Solution

Workaround:
In the case where the problem is with the MarkPSTs function, the setting "Mark PST files" can be set to "Off" in the Exchange Desktop Policy (Advanced tab > List settings from Outlook).
 
No workaround exists for the case where the problem is with Vault Cache.
 
Formal resolution:
Both cases have been addressed as part of the following release:

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)