Event ID 2850 "Whilst post processing a message an error occurred" is seen during archiving run

Event ID 2850 "Whilst post processing a message an error occurred" is seen during archiving run

  • Article ID:100022048
  • Last Published:
  • Product(s):Enterprise Vault

Problem

Event ID 2850 "Whilst post processing a message an error occurred" is seen during archiving run

Error Message

EventId: 2850
Event Category: Archive Task

Whilst post processing a message an error occurred in CArchivingAgent::PostProcessArchivedItem() whilst calling CExchangeShortcutAccessor::BuildFromSessionAndLocation().

Error returned from BuildFromSessionAndLocation(): 80004005

V-437-2850

 

Dtrace shows:

343195            07:27:19.741     [11956]            (ArchiveTask)    <7320> EV:L     :AgentMessageDispenser::ActivateObject() |Called server side object, with arguments: |m_pIArchivingAgentUpdate->PostProcessArchivedItem(OriginatingAgent = "1F7BE328E080E1B4C962B5969B43D0A311011z00EVSSite01",|  m_pIShortcutAccessor,|  m_pILocation,|  SavesetID = "201202270310570~201202051750490000~Z~111B14FA1C3EF78DFFDD1E13473ED251",|  VaultID = "1337186EAFE272747864FE3DDED5C4BFB1110000EVSSite01",|  nRetryCount = 1,|  NULL);| |
1343590            07:27:20.413     [11956]            (ArchiveTask)    <7320> EV~E   Event ID: 2850 Whilst post processing a message an error occurred in CArchivingAgent::PostProcessArchivedItem() whilst calling CExchangeShortcutAccessor::BuildFromSessionAndLocation().| |Error returned from BuildFromSessionAndLocation(): 0x80004005 |
1343595            07:27:20.413     [11956]            (ArchiveTask)    <7320> EV:H    CArchivingAgent::PostProcessArchivedItem Time Taken to Post Process Item - 201202270310570~201202051750490000~Z~111B14FA1C3EF78DFFDD1E13473ED251: 0.664512 secs
1343596            07:27:20.413     [11956]            (ArchiveTask)    <7320> EV:L     CArchivingAgent::PostProcessArchivedItem (Exit) |Unspecified error  [0x80004005] |

Cause


This error has been observed when Enterprise Vault is trying to process the A1 queue and the Exchange server or information store is unavailable at the time.

There can be two conditions that cause this issue.

1.  A Mailbox move has occurred during an Archive run or after the Provisioning Task and prior to the Archive Run.  The Provisioning Task must be run immediately after the Mailbox move and before the Archive run.

2.  A Mailbox move occurred while mail items were still in "archive pending".  
 

Solution

To fix it, you can either move the mailbox back to its original server, or perform the following actions.


1. Cancel the pending actions by following the instructions here:   000028261
2. Re-run provisioning task to update mailbox locations.
3. Reset the Pending Shortcut Timeout to its original value, and synchronize mailbox policies including folder hierarchy and permissions.


Afterward the mailbox archiving task should run with awareness of the mailbox's new location, and thus without the 2850's.



Further Reading

To avoid this problem in future Exchange migrations, the best practices for moving mailboxes from one Exchange Server to another are linked in the related documents below.
 

Related Articles

How to cancel items in an "archive pending" state in Enterprise Vault (EV) for Microsoft Exchange.

How to move archive-enabled mailboxes from one Exchange server to another

References

UMI : V-437-2850

Was this content helpful?