Problem
This has been observed when installing either NetBackup Client, Media Server or Master Server.
Error Message
During the NetBackup install process, the following error message is observed in the NetBackup Install Log.
Example path: C:\ProgramData\Symantec\NetBackup\InstallLogs
This is the error when it occurs during installation of NetBackup 7.7.3:
06-20-2018,10:11:28 : Action 10:11:28: rollbackPBX.B2D5B6C9_4698_42F7_AC9D_955789A69556. Rolling back VxPBX install
06-20-2018,10:11:28 : Action 10:11:28: CreatePBXScripts.B2D5B6C9_4698_42F7_AC9D_955789A69556.
06-20-2018,10:11:28 : An unexpected error occured while installing Symantec Private Branch Exchange. The error desfcription follows: Error Number : -2147319779 Error Description : Source : Method Name : createPBXScripts Operation : Creation of Scripting.FileSystemObject object
06-20-2018,10:11:28 : Action ended 10:11:28: InstallExecute. Return value 3.
This is the error when it occurs during installation of NetBackup 7.6.0.1:
06-12-2014,10:31:18 : Action 10:31:18: CreatePBXScripts.B2D5B6C9_4698_42F7_AC9D_955789A69556.
06-12-2014,10:31:18 : An unexpected error occured while installing Symantec Private Branch Exchange. The error desfcription follows:Error Number : 432Error Description : File name or class name not found during Automation operationSource : Microsoft VBScript runtime errorMethod Name : createPBXScriptsOperation : Creation of Scripting.FileSystemObject object
06-12-2014,10:31:18 : Action ended 10:31:18: InstallExecute. Return value 3.
This is the error when it occurs during installation of NetBackup 7.5 GA:
An unexpected error occurred while installing Symantec Private Branch Exchange. The error description follows:
Error Number : - 2147319779
Error Description :
Source :
Method Name : createPBXScripts
Operation : Creation of Scripting.FileSystemObject object
Error found in MSI Install:
04-22-2009,03:46:07 : Action 3:46:07: noteDepSvcsWeStop.B2D5B6C9_4698_42F7_AC9D_955789A69556.
04-22-2009,03:46:56 : Action ended 3:46:56: InstallExecute. Return value 3.
Note: For NetBackup installation log path, depending on your version, they're found in the following paths...
- Older Versions:
%ALLUSERSPROFILE%\Symantec\NetBackup\InstallLogs\
- Newer Versions:
%ALLUSERSPROFILE%\Veritas\NetBackup\InstallLogs\
Cause
This issue is caused by an environmental problem with vbscript library registration.
Solution
To resolve this issue, re-register the scrrun.dll file from the C:\Windows\SysWOW64 directory.
- Open a Command Prompt by clicking on the Start button, select Run, type "
cmd
", and press Enter. - Change to the following directory...
- A. (if 64-bit)
cd "C:\Windows\SysWOW64"
- B. (if 32-bit)
cd "C:\Windows\System32"
- A. (if 64-bit)
- Type the following command:
regsvr32 scrrun.dll
and press Enter.- The confirmation message received should state:
RegSvr32 - DllRegisterServer in scrrun.dll succeeded.
- The confirmation message received should state:
- Retry the installation of the NetBackup.