Event 8390 - Ran out of memory - 0xc0041c0e

Problem

Enterprise Vault fails to perform search request.  If a user has a large archive that contains hundreds of thousands or perhaps millions of folders, a problem can manifest when a search is performed.  The underlining issue occurs as a result of each folder having a large list of security descriptors.  To perform the search, EV has to create and build a filter in the server’s RAM.  It will then determine which of the subsequent folders the user has the ability to search against.  The information gathered is then passed to the Index Server when the results are available.  If the archive is large any search performed via the Integrated Search, Browser Search or Archive Explorer will fail and the following events will be displayed in the event viewer.

Error Message

Event ID: 8390
Event Category: Index Server
Description: The EnterpriseVault.DirectoryConnection object reported an error. Ran out of memory
V-437-8390
 

Event ID: 8391
Event Category: Directory Service
Description: The EnterpriseVault.DirectoryConnection object reported an error. Ran out of memory
V-437-8391
 

Event ID: 7182
Event Category: Web Application (WP)
Description: Index Search Failed: Internal reference 0xc0041c0e
V-437-7182
 

Event ID: 13360
Event Category: Directory Service
Description: An error was detected while accessing the Vault Database [DB Name]. Not enough storage is available to complete this operation
V-437-13360

Cause

This occurs when searching an archive with a large number of folders while using Integrated Search, Browser Search or Archive Explorer.

Workaround:
Data will need to be restored and re-archived with a different configuration ensuring that the amount of information is split across multiple smaller archives and not one large archive.

Solution

This issue has been resolved in the following releases:

Enterprise Vault 8.0 SP3
http://www.symantec.com/docs/TECH63623

Enterprise Vault 9.0
http://www.symantec.com/docs/DOC2774
 

 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)