4.0MPX installation program fails to detect 5.3 OS level and aborts the installation.

Problem

4.0MPX installation program fails to detect 5.3 OS level and aborts the installation.

Error Message

CPI ERROR V-9-10-1167 Cannot install Cluster Server on system as its AIX version is 5.3.7 which is not supported with this release. Cluster Server 4.0.1.0 is supported on versions 5.3.0.

Solution

IBM has changed the version number of bos.rte with AIX 5.3 TL 07 which is checked by CPI script. Based on the new version it is returning 5.3.7.0 which has broken the installation script as the CPI script checks for 5.3.0.

Solution:

Symantec is providing a new Perl module as a workaround to this installation problem.

Workaround Steps:
     1.  Copy the Perl module aix_5.3_oslevel.pl to /var/tmp
     2.  Usage:
         For fresh installation with 4.1_5.3 GA release media:
./install<prod> -require /tmp/aix_5.3_oslevel.pl

Example:
./installvcs -require /tmp/aix_5.3_oslevel.pl

         
         For maintenance pack installation with 4.0MP4 release media:
./installmp -require /tmp/aix_5.3_oslevel.pl

         For maintenance pack installation with 4.0MP3 release media:
          ./installmp -require /tmp/aix_5.3_oslevel.pl

         For Storage Foundation Cluster File System release media:
          ./installsfcfs -require /tmp/aix_5.3_oslevel.pl

          etc.



NOTE: VCS, Storage Foundation, Storage Foundation Cluster File System, and Storage Foundation for Oracle Real Application clusters are all affected by this bug.
NOTE: This is not a Symantec bug. The CPI scripts started to fail as a result of  the change made to bos.rte's version number.


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)