Track Alignment may not work correctly in Storage Foundation for Windows 5.0.

Problem

Track Alignment may not work correctly in Storage Foundation for Windows 5.0.

Solution

Track Alignment is enabled, but not enforced for an array with Track Alignment settings configured in Storage Foundation for Windows (SFW) 5.0.
Conditions:
  • The array is listed in the SFW Veritas Enterprise Administrator (VEA) User Interface -> Control Panel -> Track Alignment Settings dialog.
  • Track Alignment is enabled in the same dialog.
  • The Vendor ID and Product ID of the Disk does not exactly match the Vendor ID and Product ID listed in the Track Alignment Settings dialog.
Cause:
The Track Alignment feature works by comparing the Vendor and Product ID read from the disks (array) against a static list; as seen in the VEA - Control Panel - Track Alignment Settings dialog. Most arrays have a static Vendor and Product ID; however, there are instances where this can change. An example is where the ProductID "RAID" can also be "RAID_5".
Affected Registry Hives:
64-bit Server:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Veritas\VxSvc\CurrentVersion\VolumeManager\TrackAlignment]

32-bit Server:
[HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\VxSvc\CurrentVersion\VolumeManager\TrackAlignment]

Answer/Resolution:
An update is available by clicking on the Download Now link below. Please note that this update stops and restarts the Veritas Storage Agent (vxvm). This will cause clustered resources to fault. It is recommended to move any clustered resources to other nodes prior to running this patch.
1. Download the attached binary (1125275_293232.exe) and extract to a temporary folder
2. Change to the 32 or 64 Folder depending on the version of Windows (32/64 bit)
3. Run "SFW50-TAV-Registry-Update.cmd" from the temporary folder
Note: This update also adds Track Alignment support for the Pillar Axiom 300 and 500 series. Following installation of the update, Track Alignment will be set to Enabled.
Note: This technote supersedes technote 292352



Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)