While installing Agent for Linux (Linux Agent) and/or Remote Media Agent for Linux (RMAL), the following warning message is encountered: "Prerequisite Warning: C++ Compatibility Pack"

Problem

While installing Agent for Linux (Linux Agent) and/or Remote Media Agent for Linux (RMAL), the following warning message is encountered: "Prerequisite Warning: C++ Compatibility Pack"

Error Message

While installing Linux Agent and/or RMAL, the following warning message is encountered:

Prerequisite Warning: C++ Compatibility Pack

The installer was unable to determine if the C++ compatibility package for applications using GNU Compiler Collection (GCC) 3.3 is installed on the computer. This package is required for this version of the Symantec Backup Exec Agent for Linux.
Install the latest version of the C++ compatibility pack.

UMI code : V-225-261

Cause

A standard library file, libstdc++.so.5 is missing. 

Solution

Red Hat Linux
Before running Linux Agent and/or RMAL on RHEL, make sure that the libstdc++.so.5 library has been installed. Currently, the libstdc++.so.5 library is provided by compat-libstdc++-33-3.2.3-68.x86_64.rpm:
yum install libstdc++.so.5. 

Note : Since the RPM package can change with the OS updates, this document will be kept updated with the Compatability Library RPM to install and instructions on how to update the systems.

 

Debian based Distributions
Before running Linux Agent and/or RMAL on a Debian based distribution, make sure that the libstdc++.so.5 library has been installed.  This can be installed using the following command at the console:
apt-get install libstdc++5
 
Note: Ubuntu is based on Debian.

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)