Final error: 0x8004231f - 0x8004231f (2147754783), is reported in the Job Log after performing a backup of Shadow Copy Components or System State on a Windows Server

Article: 100016904
Last Published: 2018-04-25
Ratings: 1 0
Product(s): Backup Exec

Problem

A Backup job of the Shadow Copy Components or System State may fail with the following error:

 

Error Message

 Final error: 0x8004231f - 0x8004231f (2147754783)

AOFO: Initialization failure on:"Shadow?Copy?Components". Advanced Open File Option used: Microsoft Volume Shadow Copy Service(VSS). VSS Snapshot error. Out of disk space or no NTFS volume found while creating snapshot.

UMI - V-79-32772-8991

Cause

1. The Volume Shadow Copy Service is disabled for the Volume to be snapped.

2. The Volume Shadow Copy Service is allocated limited amount of space which is not sufficient for the creation of snap.

3. The VSS writers are unstable or have a failed status.

4.  The System Reserve partition (100MB) has less than 50MB free 

 

Solution


1. Right-click My Computer and select Manage. Expand Services and Applications and select Services.  Check to see if Volume Shadow Copy service is set to Manual.


2. Set the Volume Shadow Copy service to Manual if it is disabled. This can be done by right-clicking on the service and selecting Properties.  Then change the Startup Type on the general tab to Manual as shown in Figure 1.

Figure 1
 


3. If Volume Shadow Copy service is already enabled, change the settings to increase the limit of the size of the Shadow Copy Snapshot as shown in Figure 2a. This can be done by right-clicking C drive from My computer to choose Properties and then from the Shadow Copies tab click on Settings in Figure 2b. This can also be set to No limit if hard disk is not a constraint.

Figure 2a
 

Figure 2b
 


This will allow the Volume Shadow Copy service to be utilized during a backup job.  The above steps will also increase the ability to store snapshots that are larger than the currently set limit.

4. Check the status of the VSS Writers using the command "vssadmin list writers"  from the command prompt. If the state for the writers are listed as failed, reboot the server and confirm the writer status again. Once writers show "Stable: No Error", proceed with the next step.

5.  If the System Reserve partition has less than 50MB free, the USN Change Journal can be deleted to free up space. Perform the following steps to free up space:

  •  Assign a drive letter to the System Reserve partition using Disk Management
  • Goto a command prompt and query the USN Change Journal using command:   fsutil usn queryjournal <drive letter:>
  • If enabled, delete the journal using command:    fsutil usn deletejournal /D <drive letter:>
  • Verify the free space on System Reserve partition & retry backup.

6.  If issues persist, then attempt to backup System State using Windows Backup. If the backup fails using the Windows native backup software, then contact Microsoft for further assistance.  

 

 

 

References

UMI : V-79-32772-8991 JIRA : 0x8004231f - 0x8004231f (2147754783) UMI : V-79-10000-11242

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