VMware VIP queries of vCloud Director in NetBackup 7.6.x fail with "nbu status = 1, severity = 1(1)"

Problem

VMware VIP queries of vCloud Director in NetBackup 7.6.x fail with "nbu status = 1, severity = 1(1)" when using the "Test Query" option in policy. It will also cause jobs to fail with a status 200 error.  Attempts to run the query using the nbdiscover command also fail with errors.

This is caused by a case sensitivity issue when dealing with the host names within VMware.  Case sensitivity of host names is recorded in vSphere.

Error Message

Test queries will fail with:
'VM retrieval failed, server = <vcloud.customer.address>., nbu status = 1, severity = 1(1)'

 

 

Test queries using the nbdiscover command line tool will fail with an entity not found or status 1 error.

 

NCFNBCS logging on the discovery host will reveal the case mismatch errors:
'get_vCloud_VMs: Found vCenter VCENTER.fqdn.com,13:vfms_virt_log,1'

'getConnection: No credentials for VCENTER.fqdn.com,13:vfms_virt_log,1'
'get_vCloud_VMs: Cannot find the credentials for the vSphere server: VCENTER.fqdn.com,13:vfms_virt_log,1'
'get_vCloud_VMs: excluding vCenter VCENTER.fqdn.com from unique vCenters list,13:vfms_virt_log,1'
Get VM call failed for vcloud.fqdn.com(../VMwareIteration.cpp:134),15:getvCloudGuests,1'
Exception thrown: get_vCloud_VMs: No vCenter credentials found for vCloud director vcloud.fqdn.com'
Problem retrieving vCloud Guests (../VMwareIteration.cpp:1966),28:VMwareIteration::doIteration,1'

And then the following message shows that NetBackup disconnects from the vCenter server with its local lower-case registered credentials:
dovSphereDisconnect: disconnect for vcenter.fqdn.com completed with flags 0 and status 0,13:vfms_virt_log,1'

 

Cause

Although case-sensitivity of vCenter servers is not taken into consideration with queries and backups directly against credentialed vCenter servers in NetBackup, it is tracked when using vCloud enabled queries. This is because vCloud subscribes to the internal name registration of the environment's vSphere server(s), which includes case sensitivity. 

Solution

Check ncfnbcs logging to determine with what case the vCenter servers are registered internally in vSphere.

Make sure that EMM matches the case sensitivity of the vCenter servers via the Administration Console (Media and Device Management>Credentials>Virtual Machine Servers) or via nbemmcmd -listhosts from the command line.

If there is a mis-match, remove them from EMM via command line or Administration Console and re-enter them with the matching case. A recycle of NetBackup services or reboot is NOT required.

 

 

Applies To

 

VMware 5.x with vCloud Director

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)