Pkgrm VRTSnetbp Failure Solaris 10

Problem

When upgrading a NetBackup master from 7.1.0.3 to 7.5 that was previously at NetBackup 5.1, the upgrade fails.

Error Message

pkgrm: ERROR: preremove script did not complete successfully

Running pkgrm VRTSnetbp manually also fails.

Cause

pkgrm VRTSnetbp fails due to the following files still existing:

/usr/openv/netbackup/bin/driver/sg.conf

/usr/openv/netbackup/bin/driver/st.conf

/usr/openv/netbackup/bin/driver/sg.links

(These files were discovered by running pkgrm -v VRTSnetbp and watching where the removal of that package failed)

Solution

Remove the files listed below:

/usr/openv/netbackup/bin/driver/sg.conf

/usr/openv/netbackup/bin/driver/st.conf

/usr/openv/netbackup/bin/driver/sg.links

 

Run pkgrm VRTSnetbp

Re-run the upgrade to NetBackup 7.5


Applies To

Solaris 10

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)