Query failed error appears viewing Backup Set on MBES server when Catalog mode is set to Centralized catalogs.

Problem

When viewing Backup sets on MMS/MBES server devices a Query failed error appears. (Figure 1)

 

Figure 1

 

 

Error Message

Query Failed

Cause

Centralized Catalog query error.

 

Debug Error


 BECAT : [3728]:[5]: odbcConn (000000001B426C80) - done
 ERROR: LocalizedException:
 ERROR:   Message: Unable to perform query for {0.EN_US}.
 ERROR:   Reason: Unknown reason: {0.EN_US}.
 ERROR:   Stack:    at BackupExec.Management.Components.MetaData.MetaDataManager.HandleQueryResult[T](List`1& resultList, MetaDataQueryResultInfo metaDataQueryResultInfo, Func`2 createFunc, ItemCriteria itemCriteria, MetaDataQueryInfo metaDataQueryInfo, Boolean allocatedMetaDataConnection)
    at BackupExec.Management.Components.MetaData.MetaDataManager.QueryBackupSet(ItemCriteria& itemCriteria)
    at SyncInvokeQueryBackupSet(Object , Object[] , Object[] )
    at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
    at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
MANAGEME: [MetaData    ] QueryMetaData ends: MDQ_BackupSet_View rc=-1 numrows=0
MANAGEME: [MetaData    ] ReleaseMetaDataConnection : 457337984
MANAGEME: [MetaData    ] ReleaseConnection : 457337984
MANAGEME: [MetaData    ] ReleaseConnection : gain lock

 

 

 

Solution

This issue is resolved in Backup Exec 2014 or later versions. 

 

To resolve this issue and receive the new Backup Exec improvements please upgrade to the current version of Backup Exec

  

 

NOTE:   Symantec continues to focus on the current release and future releases, there are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time. Please contact your Symantec Sales representative or the Symantec Partner for upgrade information including upgrade eligibility to the release containing the resolution for this issue. For information on how to contact Symantec Sales, please see  http://www.symantec.com

.

 


Applies To

Backup Exec 2012 SP2

Enterprise Server Option

CASO/MBES - Catalog Mode Centralized

 

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