RALUS agent may crash on initialization on server running Oracle Linux 6.1 with Kernel version 2.6.39-*

Problem

On Oracle Linux 6.1 with Kernel version 2.6.39-100.5.1, the RALUS agent gets installed successfully but crashes while starting up.

Error Message

The ralus crash dump shows

/lib/libc.so.6(+0x77806)[0x7f598b2c1806]
/opt/VRTSralus/bin/libbesocket.so(_Z11freeifaddrsP7ifaddrs+0x1f)[0x7f598d12057f]
/opt/VRTSralus/bin/libbesocket.so(_Z10getifaddrsPP7ifaddrs+0x3a7)[0x7f598d120967]
/opt/VRTSralus/bin/libbesocket.so(_Z20GetAdaptersAddressesjjPvP21_IP_ADAPTER_ADDRESSESPj+0x53)[0x7f598d121b93]
/opt/VRTSralus/bin/libbesocket.so(_ZN8BESocket13BENetConfigEx18RefreshInformationEPKb+0x3a)[0x7f598d12a17a]
/opt/VRTSralus/bin/libbesocket.so(_ZN8BESocket13BENetConfigExC1Eb+0x18b)[0x7f598d12a40b]
/opt/VRTSralus/bin/libbesocket.so(_ZN8BESocket13BENetConfigEx23GetNetworkConfigurationEb+0x21)[0x7f598d12a951]
/opt/VRTSralus/bin/libbedsvx.so(_Z14VX_EnumSelfDLEP6BE_CFGP8HEAD_DLE+0x301)[0x7f598e6128b1]
/opt/VRTSralus/bin/libndmpcomm.so(+0x41165)[0x7f598d7be165]
/opt/VRTSralus/bin/libndmpcomm.so(+0x41654)[0x7f598d7be654]
/opt/VRTSralus/bin/libndmpcomm.so(_Z20NrdsAdvertiserThreadPv+0x72e)[0x7f598d7bf37e]
/opt/VRTSralus/bin/libvxACE.so.6(_ZN2v618ACE_Thread_Adapter8invoke_iEv+0x55)[0x7f599120e2d5]
/opt/VRTSralus/bin/libvxACE.so.6(_ZN2v618ACE_Thread_Adapter6invokeEv+0x5a)[0x7f599120e23a]
/lib/libpthread.so.0(+0x69ca)[0x7f598f94f9ca]
/lib/libc.so.6(clone+0x6d)[0x7f598b330cdd]

Cause

This is a Kernel specific issue with the Linux Kernel 2.6.39 

Solution


A hotfix is now available for this issue in the current version(s) of the product(s) mentioned in this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.

Backup Exec 2012 Rev 1798 Service Pack 4 (TECH212772).
 

 

Workaround:

Customers facing this issue are requested to check the following link and should contact the Linux support to apply the following patch:

https://bugzilla.kernel.org/show_bug.cgi?id=33992

 


Applies To

Media server is running BE 2012

BE 2012 RALUS agent running on Linux server OEL 6.1 with Kernel version 2.6.39-100.5.1.

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)