User account not visible in Windows SBS Console after restoring a mailbox

  • Article ID:100010177
  • Modified Date:
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Problem

When performing a Granular Restore Technology (GRT) restore of a user's mailbox in an SBS 2011 environment, if the option to "Recreate user accounts and mailboxes if they do not already exist on the destination server" is selected, then any created user accounts are not visible in the Windows SBS console even though the accounts have been created in Active Directory.

Note: This issue was reported against SBS 2011 when backing up and restoring with Backup Exec 2012, however, other combinations of SBS and Backup Exec versions may be affected in the same way.

Cause

SBS uses specific AD Object attributes to identify what to display in the Windows SBS Console. The option to "Recreate user accounts and mailboxes if they do not already exist on the destination server" does not currently recreate these attributes.

 

 

Solution

If mailbox restores have not yet been performed then it is recommended that users are manually created using the Windows SBS before restoring the mailboxes and that the option to create the user accounts is not selected. However if mailbox restores have already been performed with the option to create AD accounts used, then actions will need to be taken within ADSI  Edit.

 Warning: Incorrect use of the ADSI Edit utility may prevent the Active Directory domain and servers within the domain from functioning properly. Great care should be taken when making changes to Active Directory. Modifications should only be carried out by persons experienced in the use of the ADSI Edit utility. It is recommended that Microsoft be consulted before making changes.
 

Use ADSI Edit to locate the recreated/affected user accounts and modify the attribute called "msSBSCreationState" and set it to "Created"

Notes:

  • SBS users are usually created in OU=SBSUsers,OU=Users,OU=MyBusiness,DC=,DC=
  • Veritas have not currently identified any other SBS specific attribute that needs change, however it is possible that other SBS functionality may be affected that requires other attributes amending.

 

Veritas Corporation has acknowledged that the above-mentioned issue is present in the current version(s) listed under the Product(s) Section of this article. Veritas Corporation is committed to product quality and satisfied customers.
 
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time. However, this particular fix is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see    https://www.veritas.com

 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

 

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